POJ-3067 Japan (树状数组)

Japan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30012 Accepted: 8082

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define maxn 1005
struct road{
    int from, to;
    bool operator < (const road& x){
        if(from == x.from) return to < x.to;
        return from < x.from;
    }
}a[500001];
int c[maxn];
inline int lowbit(int x){
    return x & (-x);
}
void add(int x){
    while(x < maxn){
        c[x]++;
        x += lowbit(x);
    }
}
int query(int x){
    int ans = 0;
    while(x){
        ans += c[x];
        x -= lowbit(x);
    }
    return ans;
}
int main(){
    int T, casenum = 1;
    long long ans;
    scanf("%d", &T);
    while(T--){
        int n, m, k;
        scanf("%d %d %d", &n, &m, &k);
        for(int i = 1; i <= k; ++i){
            scanf("%d %d", &a[i].from, &a[i].to);
        }
        sort(a + 1, a + 1 + k);
        memset(c, 0, sizeof(c));
        ans = 0;
        for(int i = 1; i <= k; ++i){
            ans += i - 1 - query(a[i].to);
            add(a[i].to);
        }
        printf("Test case %d: %lld\n", casenum++, ans);
    }
    return 0;
}   

/*
题意:左边一排城市,右边一排城市,中间有一些街道连接两两城市,问有多少街道交叉。

思路:
街道交叉其实就表现为街道两边的城市,左边在下的城市,连接右边在上的城市。所以我们按
左边的城市从上到下排序这些街道,用树状数组维护右边的城市出现的位置,后面的街道,因为
左边在下面出现,所以想要交叉,右边就得出现在上面,这样我们只需要询问当前街道右边城市
的下面有多少个城市就有多少次交叉。树状数组的简单应用。
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值