1025 PAT Ranking

1025 PAT Ranking (25 point(s))

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

本题给出PAT不同城市考生的成绩,要求分别给出考生的总排名和城市排名。需要注意的是,相同分数的人排名需要相同。

注意点:

1. 排名赋值方法,解决同分同名次问题(为了方便,这里count是从1开始计数的)。

2. 对于分城市的排名,当遍历到城市序号对应的时候开始操作。和总排名不一样的是,需要记录上一个排名到的城市,而不能像排总名次那样直接和上一个比较。

解题过程中踩坑:

1.  因为count是从1开始计数,所以sort的两个迭代器分别是r+1,r+1+count-1=r+count。否则测试点2、3不能通过。

2. 分城市的for循环中,if语句不能作为for的第二个参数。因为for循环进入循环体时不会首先判断是否满足限制。否则测试点0、2、3不通过。

#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
struct record{
	string id;
	int grade,final_rank,loc_id,loc_rank;
	bool operator < (const record &other) const{
		if(grade!=other.grade) return grade>other.grade;
		else return id<other.id;
	}
}; 
record r[30010];
int main(void)
{
	int N,K;
	int count=1;
	cin>>N;
	for(int i=1;i<=N;i++){
		cin>>K;
		for(int j=0;j<K;j++){
			cin>>r[count].id>>r[count].grade;
			r[count].loc_id=i;
			count++;
		}
	}
	sort(r+1,r+count);
	for(int i=1;i<=count;i++){
		if(i==1||r[i].grade!=r[i-1].grade) r[i].final_rank=i;
		else r[i].final_rank=r[i-1].final_rank;
	}
	for(int i=1;i<=N;i++){
		int lr = 1;int last_locid=1;
		for(int j=1;j<=count;j++){
			if(r[j].loc_id==i){
				if(lr==1||r[j].grade!=r[last_locid].grade) r[j].loc_rank=lr;
				else r[j].loc_rank=r[last_locid].loc_rank;
				lr++;
				last_locid=j;
			}
		}
	}
	cout<<count-1<<endl;
	for(int i=1;i<=count-1;i++){
		cout<<r[i].id<<" "<<r[i].final_rank<<" "<<r[i].loc_id<<" "<<r[i].loc_rank<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值