1059 Prime Factors

1059 Prime Factors (25 point(s))

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

此题也是华中科技大学2019年夏令营机考题目。

思路:

1. 素数筛法(一般计算到1e4,1e5会爆)

2. 从小到大枚举素数,判断是否可以整除,散列表记录指数。

3. 注意大素数的情况。

踩坑:

测试点4的输入是1。(否则23分)

事后反思:

此题其实不适合用素数筛法,因为它限制了我们可以找到的素数范围。普通素数处理方法即可。参考链接:https://blog.csdn.net/acm_ted/article/details/20300017

#include<iostream>
#define LL long long 
using namespace std;
const int N = 1e4+7; 
bool mark[N]={false};
int prime[N];
int exp[N]={0};
int primeCount=0;
void init(){
	for(int i=2;i<N;i++){
		if(mark[i]) continue;
		for(int j=i*i;j<N;j=j+i){
			mark[j]=true;
		}
	}
	for(int i=2;i<N;i++){
		if(!mark[i]) prime[primeCount++]=i;
	}
	//for(int i=0;i<primeCount;i++) cout<<prime[i]<<endl;
}
int main(void){
	init();
	LL N,NUM;
	cin>>NUM;
	N=NUM;
	int idx = 0;
	while(N!=1){
		//cout<<N<<endl;
		if(N%prime[idx]==0){
			while(N%prime[idx]==0){
				N=N/prime[idx];
				exp[idx]++;
			}
		}
		idx++;
		if(idx>=primeCount) break;
	} 
	if(N!=1) {
		prime[primeCount]=N;
		exp[primeCount]=1;
		primeCount++;
	}
	cout<<NUM<<"=";
	bool flag = false;
	for(int i=0;i<idx;i++){
		if(exp[i]!=0){
			if(flag) cout<<"*";
			flag=true;
			if(exp[i]==1) cout<<prime[i];
			else cout<<prime[i]<<"^"<<exp[i];
		}
	}
	if(N!=1) cout<<"*"<<N;
	if(NUM==1) cout<<"1";
	cout<<endl;
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值