1059 Prime Factors (25 分)(质因子分解)

1059 Prime Factors (25 分)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1kp2k2×⋯×pmk**m.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1*p2^k2**p**m^k**m, where p**i’s are prime factors of N in increasing order, and the exponent k**i is the number of p**i – hence when there is only one p**i, k**i is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

思考:

​ 质因子分解的问题,可以定义factor,结构体里包括一个整数中包含的质因子x和质因子个数,打印素数表,由于对于一个正整数n,如果存在因子那么一定是sqrt(n)两侧成对出现,那么对于质因子也是一样的,只需要循环[2,sqrt(n)]内的因子即可,如果存在[2,n]的质因子,要么是在[2,sqrt(n)],否则只存在一个大于sqrt(n)的质因子,即n本身。

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=100005;
struct factor{
	int x;
	int cnt;
}fac[10];
bool isprime(int n){
	if(n<=1) return false;
	int sqr=(int)sqrt(1.0*n);
	for(int i=2;i<=sqr;i++){
		if(n%i==0){
			return false;
		} 
	}
	return true;
}
int prime[maxn],pnum=0;
bool p[maxn]={0};
void find_prime(){
	for(int i=1;i<maxn;i++){
		if(isprime(i)){
			prime[pnum++]=i;
			p[i]=true;
		}   
	}
	
}
int main(){
	
	//ifstream cin("1.txt");
	
	find_prime();
	long long n;
	cin>>n;
	cout<<n<<"=";
	if(n==1) {
		cout<<1<<endl;
		return 0;
	}
	
	int sqr=(int)sqrt(1.0*n);
	int num=0;
	for(int i=0;i<pnum&&prime[i]<=sqr;i++){//如果prime[i]是n的因子 
		if(n%prime[i]==0){
			fac[num].x=prime[i];// 记录该因子 
			fac[num].cnt=0;
			while(n%prime[i]==0){//计算出质因子prime[i]的个数 
				fac[num].cnt++;
				n/=prime[i];
			}
			num++;
		}
		if(n==1) break;
	}
	if(n!=1){
		fac[num].x=n;
		fac[num++].cnt=1;
	}
	
	
	for(int i=0;i<num;i++){
		if(i!=0) cout<<"*";
		if(fac[i].cnt!=1){
			cout<<fac[i].x<<"^"<<fac[i].cnt;
		}
		else{
			cout<<fac[i].x; 
		} 
	}
	
	
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值