1078 Hashing (25 point(s))

1078 Hashing (25 point(s))

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then Ndistinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

翻译:Quadratic probing(with positive increments only) 正向平方探测法 

参考链接:https://blog.csdn.net/qq_37142034/article/details/87903983

体会哈希思想(哈希表)的应用。

特别的坑:注意到输入最大为1e4,因此应当至少能够判断出大于1e4的最小素数。由于我这里用的是素数筛法,我最初习惯性地将数组大小开为1e4+7,由此可以使用素数筛法可以筛选到的最大素数范围是2~1e4+6,而恰巧比10000大的最小素数是1e4+7,导致case#3和case#4一直不能通过(15分)。

#include<iostream>
using namespace std;
const int N = 10013;
bool mark[N]={false};
int prime[N];
int ht[N];
int index = 0;
void init(){
	for(int i=2;i<N;i++){
		if(mark[i]) continue;
		for(int j=i*i;j<N;j=j+i){
			mark[j]=true;
		}
	}
	for(int i=2;i<N;i++){
		if(!mark[i]) prime[index++]=i;
	} 
}
int main(void){
	init();
	int M,N,size,key;
	cin>>M>>N;
	for(int i=0;i<index;i++){
		if(prime[i]>=M){
			size = prime[i];break;
		} 
	} 
	for(int i=0;i<size;i++) ht[i]=-1;
	for(int i=0;i<N;i++){
		cin>>key;
		if(i!=0) cout<<" ";
		int pos = key%size;
		if(ht[pos]==-1){//hash表该项为空 
			ht[pos]=key;
			cout<<pos;
		}
		else{//发生冲突,线性平方探测
			bool flag =false;
			for(int i=1;i<=size-1;i++){
				int npos = (key+i*i)%size; 
				if(ht[npos]==-1){
			 		cout<<npos;
					ht[npos]=key;
			 		flag=true;
					break;
				}
			}
			if(!flag) cout<<"-";
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值