1048 Find Coins (25 point(s))

1048 Find Coins (25 point(s))

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=Mand V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

思想:Hash表

题意:在一个数组中寻找恰好两个数(不超过500),让其组成恰好等于M(不超过1000)。并由小到大输出这两个数,如果多组解,则输出第一个数小的解。

基本思路: 构建哈希表,记录每一个数的个数cnt[i]。由小到大遍历哈希表,如果cnt[i]>=1&&cnt[M-i]>=1,则得到结果。注意判断两个相同的硬币组成M的情况。

踩坑:case#3段错误(23分)

由于数组大小刚好是500,在判断的时候M-i可能大于500,因此出现段错误。解决方案:1. 数组长度改为1001;2. 判断M-i<=500。

#include<iostream>
using namespace std;
const int MAX = 507;
int cnt[MAX]={0};
int main(void){
	int N,M,a;cin>>N>>M;
	for(int i=0;i<N;i++){
		cin>>a;
		cnt[a]++;
	}
	bool flag=false;
	for(int i=1;i<=M;i++){
		if(i+i==M){
			if(cnt[i]>=2){
				cout<<i<<" "<<i<<endl;
				flag=true;
				break;
			}
		}
		else{
			if(cnt[i]>=1&&M-i<=500&&cnt[M-i]>=1){
				cout<<i<<" "<<M-i<<endl;
				flag=true;
				break;
			}
		}
	}
	if(!flag) cout<<"No Solution"<<endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值