【PAT甲级】1048 Find Coins(散列/二分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

题目大意

这题是散列算法的应用。就是给出n个硬币面额,还有一个目标金额m,如果n个硬币面额中存在两个n1 + n2 = m,则输出n1最小的n1、n2组合。如果不存在则输出No Solution。

个人思路1:散列

这题设立了一个数组cnt存放下标数额的硬币数量,然后从0到500遍历,如果存在i和m-i都有,则输出i和m-i。

注意有可能存在两个硬币的面额相等,所以在选择一个面额的时候要把其数量-1,如果该方案不行,再+1。

代码实现1

#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#include <algorithm>
#include <iostream>
#define ll long long
#define eps 1e-8
#define INF 0x7FFFFFFF
using namespace std;
const int maxn = 100005;
int cnt[505];

int main() {
    // 初始化
    memset(cnt, 0, sizeof(cnt));
    // 输入并记录数量
    int n, m;
    cin >> n >> m;
    for (int i = 0; i < n; i ++) {
        int tmp;
        cin >> tmp;
        cnt[tmp] ++;
    }
    // 从小到大遍历,如果找到答案就输出并结束程序
    for (int i = 0; i <= 500; i ++) {
        if (cnt[i] > 0 && m-i <= 500) {
            cnt[i] --;
            if (cnt[m-i] > 0) {
                cout << i << " " << m-i;
                return 0;
            }
            cnt[i] ++;
        }
    }
    // 没有找到方案
    cout << "No Solution";
    return 0;
}

个人思路2:二分

先将所有硬币从小到大排序,然后逐个选择作为第一个硬币x,令第二个硬币y=m-x,如果y比500大说明这种情况不可以,如果y比500小则在当前硬币之后的所有硬币中二分查找是否存在数值为y的硬币,如果存在则输出并退出循环,如果不存在则输出No solution

实现代码2

#include <cstdio>
#include <algorithm>
#include <vector>
#include <iostream>
#define ll long long
using namespace std;
const int maxn = 100005;

bool bi_search(int a[], int left, int right, int y) {
    int mid;
    while (left <= right) {
        mid = (left + right) / 2;
        if (a[mid] > y) right = mid - 1;
        else if (a[mid] == y) return true;
        else left = mid + 1;
    }
    return false;
}

int main() {
    int n, m, coins[maxn];
    cin >> n >> m;
    for (int i = 0; i < n; i ++)
        cin >> coins[i];
    sort(coins, coins+n);
    bool flag = false;
    int x = 0, y = 0;
    for (int i = 0; i < n; i ++) {
        x = coins[i];
        y = m - x;
        if (y > 500) continue;
        if (bi_search(coins, i+1, n-1, y)) {
            flag = true;
            break;
        }
    }
    if (!flag) cout << "No Solution" << endl;
    else cout << x << " " << y;
    
    return 0;
}

总结

学习不息,继续加油

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值