1004 Counting Leaves (30 point(s))
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a given non-leaf node, K
is the number of its children, followed by a sequence of two-digit ID
's of its children. For the sake of simplicity, let us fix the root ID to be 01
.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority levelstarting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01
is the root and 02
is its only child. Hence on the root 01
level, there is 0
leaf node; and on the next level, there is 1
leaf node. Then we should output 0 1
in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1
题意:计算一棵树的每一个层次的叶子节点。
思路:深度优先搜索(广度优先搜索也可以),注意标记每个结点所在的层次。直到该节点没有儿子节点结束,根据该节点的层次,cnt[]自增。
BFS参考大神链接:https://blog.csdn.net/richenyunqi/article/details/79533166
#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
const int MAX = 107;
vector<int> graph[MAX];
int level[MAX]={0};
int cnt[MAX]={0};
int maxLevel = 0;
void dfs(int v){
if(graph[v].size()==0){
cnt[level[v]]++;
return;
}
for(int i=0;i<graph[v].size();i++){
int cur = graph[v][i];
level[cur]=level[v]+1;
maxLevel = max(maxLevel,level[cur]);
dfs(cur);
}
}
int main(void){
int N,M;cin>>N>>M;
int id,k,a;
while(M--){
cin>>id>>k;
while(k--){
cin>>a;
graph[id].push_back(a);
}
}
int root = 1;
dfs(root);
for(int i=0;i<=maxLevel;i++){
if(i==0) cout<<cnt[i];
else cout<<" "<<cnt[i];
}
return 0;
}