PAT(A)1121 Damn Single (25point(s))

在这里插入图片描述

Sample Input

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output

5
10000 23333 44444 55555 88888

思路:
map记录输出。
代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
#include <vector>
#include <map>
#include <cmath>

using namespace std;

#define endl '\n'

typedef long long ll;

map<string, string>mp;
map<string, int>mp1;

vector<string>v1;
vector<string>v2;

int main()
{
    int n;
    cin >> n;

    for (int i = 0; i < n; ++i)
    {
        string x, y;
        cin >> x >> y;
        mp[x] = y;
        mp[y] = x;
    }

    int m;
    cin >> m;

    for (int i = 0; i < m; ++i)
    {
        string x;
        cin >> x;
        mp1[x] = 1;
        v1.push_back(x);
    }

    for (int i = 0; i < v1.size(); ++i)
    {
        if (mp1[mp[v1[i]]] != 1)
            v2.push_back(v1[i]);
    }

    sort(v2.begin(), v2.end());

    cout << v2.size() << endl;

    for (int i = 0; i < v2.size(); ++i)
    {
        cout << v2[i];
        if (i != v2.size() - 1)
            cout << " ";
    }

    // cout << endl;

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值