1121 Damn Single(25 分)(PAT甲级)

 

题目描述:
 

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

 

Sample Output:

5
10000 23333 44444 55555 88888

代码如下:

#include <iostream>
#include <vector>
#include <algorithm>
#include <cstdlib>
#include <map>
#include <string>
using namespace std;
const int maxn = 50010;
int s3[maxn];
vector<int> res;

struct node {            //flag表示是否为夫妻,com表示是否来这次聚会(因为夫妻都来聚会才算)
	int num;
	int flag;
	int com;
	node() {
		num = 0;
		flag = 0;
		com = 0;
	}
};
map<int, node> mp;
int main()
{
	int s1, s2;
	int n, m, index = 0, vaule;
	cin >> n;
	for (int i = 0; i < n; i++) {        //输入夫妻,并标记flag
		cin >> s1 >> s2;
		mp[s1].num = s2;
		mp[s2].num = s1;
		mp[s1].flag = 1;
		mp[s2].flag = 1;
	}
	cin >> m;
	for (int i = 0; i < m; i++) {        
		cin >> vaule;
		if (mp[vaule].flag == 0)        //如果没有对象,直接存入结果
			res.push_back(vaule);
		else {
			s3[index++] = vaule;        //否则存入中间数组,并标记com
			mp[vaule].com = 1;
		}
	}
	for (int i = 0; i < index ; i++) {
		if (mp[s3[i]].com == 1 && mp[mp[s3[i]].num].com == 1)
			continue;            //如果夫妻都来了,跳过这轮循环,否则存入结果
		else
			res.push_back(s3[i]);		
	}
	sort(res.begin(), res.end());
	printf("%d\n", res.size());
	for (int i = 0; i < res.size(); i++) {
		printf("%05d", res[i]);
		if (i < res.size() - 1)
			printf(" ");
	}
	system("pause");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值