1124 Raffle for Weibo Followers (20 point(s))

1124 Raffle for Weibo Followers (20 point(s))

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

简单模拟。

发牢骚:这题意思不太明确吧。如果在第i个的时候,考虑到了下一个获奖者i+1,那接下来的应该是循环到i+N还是i+N+1,实际应该是后者,但是题目的every N followers理解成每N个的话,我觉得有点争议。

#include<iostream>
#include<cstring>
#include<unordered_set>
#include<vector>
using namespace std;
int M,N,S;
const int MAX =1007;
string s[MAX];
unordered_set<string> ans;
int main(void){
	cin>>M>>N>>S;
	for(int i=1;i<=M;i++){
		cin>>s[i];
	}
	for(int i=S;i<=M;i=i+N){
		while(i<=M){
			if(ans.find(s[i])==ans.end()){
				cout<<s[i]<<endl;
				ans.insert(s[i]);
				break; 
			}
			i++;
		}
	}
	if(ans.empty()) cout<<"Keep going..."<<endl;
	return 0;
} 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值