1133 Splitting A Linked List (25 point(s))
Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤103). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address
is the position of the node, Data
is an integer in [−105,105], and Next
is the position of the next node. It is guaranteed that the list is not empty.
Output Specification:
For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218
Sample Output:
33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1
链表的操作。
1. 按照头节点指针确定在链表中的结点;
2. 按照结点元素大小3次顺序遍历;
3. 输出(注意最后一个节点的next指针是-1)。
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int MAX = 1e5+7;
struct Node{
int address,key,nextAdd;
};
Node node[MAX];
int start,N,K;
int main(void){
cin>>start>>N>>K;
int a,k,n;
while(N--){
cin>>a>>k>>n;
node[a].address=a;
node[a].key=k;
node[a].nextAdd=n;
}
vector<Node> v;
while(start!=-1){
v.push_back(node[start]);
start = node[start].nextAdd;
}
vector<Node> ans;
for(int i=0;i<v.size();i++){
if(v[i].key<0) ans.push_back(v[i]);
}
for(int i=0;i<v.size();i++){
if(v[i].key>=0&&v[i].key<=K) ans.push_back(v[i]);
}
for(int i=0;i<v.size();i++){
if(v[i].key>K) ans.push_back(v[i]);
}
for(int i=0;i<ans.size()-1;i++) printf("%05d %d %05d\n",ans[i].address,ans[i].key,ans[i+1].address);
printf("%05d %d -1\n",ans.back().address,ans.back().key);
return 0;
}