1133 Splitting A Linked List (25point(s)) - C语言 PAT 甲级

1133 Splitting A Linked List (25point(s))

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤103). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−105,105​​], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

题目大意:

1075 链表元素分类 (25point(s))

设计思路:

1075 链表元素分类(C语言)

  1. 题目中链表的地址从小到大排列,故可以利用数组下标当链表地址
  2. 两个数组分别记录链表数据,链表 next 地址
  3. 遍历链表输出
编译器:C (gcc)
#include <stdio.h>

int main()
{
        int data[100000] = {0}, next[100000] = {0};
        int n, k, first, addr, last = -1;
        int i;

        scanf("%d %d %d", &first, &n, &k);
        for (i = 0; i < n; i++) {
                scanf("%d", &addr);
                scanf("%d %d", data + addr, next + addr);
        }

        for (i = 0; i < 3; i++) {
                for (addr = first; addr != -1; addr = next[addr]) {
                        if ((i == 0 && data[addr] < 0)
                        ||  (i == 1 && 0 <= data[addr] && data[addr] <= k)
                        ||  (i == 2 && data[addr] > k)) {
                                if (last != -1)
                                        printf(" %05d\n", addr);
                                printf("%05d %d", addr, data[addr]);
                                last = addr;
                        }
                }
        }
        printf(" -1\n");

        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值