【模板】拓扑排序 (Legal or Not题解)

作用:判断一个有向图是不是有向无环图(DAG)。

步骤:

1.邻接矩阵map[][]存储有向边的信息,indegree[]存储每一个结点的入度。

2.在有向图中寻找一个入度为0(没有前驱)的结点并记录。

3.删除该结点(indegree[i]置为-1)以及以该结点作为起点的边(若map[i][j]==1则置为0,同时indegree[j]--)。

4.重复步骤2和3,直到所有结点都输出,此时结点的输出序列就是一个拓扑排序。若不能把所有结点输出,则说明该有向图当中有环。

应用:课程先修问题、师傅徒弟问题、排名问题等。

Legal or Not

来源:王道论坛

题目描述

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

输入


The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

输出

For each test case, print in one line the judgement of the messy relationship.If it is legal, output "YES", otherwise "NO".

样例输入

4 3
0 1
1 2
2 3
3 3
0 1
1 2
2 0
0 1


样例输出

YES
NO
//Legal or not
//拓扑排序
//目的:检验有向图中是否为有向无环图(DAG) 
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int map[101][101];//邻接矩阵存储是否存在有向边 
int indegree[101];//记录每一个结点的入度
int main(void)
{
	int n,m;//n个点,m条有向边
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==0&m==0) break;
		memset(map,0,sizeof(map));
		memset(indegree,0,sizeof(indegree));
		int x,y;
		for(int i=0;i<m;i++){
			scanf("%d%d",&x,&y);//x是y的师傅
			map[x][y]=1;
			indegree[y]++;//y的入度加1 
		}
		int count=0;
		for(int k=0;k<n;k++){//最多尝试寻找n次 
			for(int i=0;i<n;i++){//遍历所有结点,寻找入度为0的 
				if(indegree[i]==0){
					count++;
					indegree[i]--;//置为-1表示已经找过
					for(int j=0;j<n;j++){
						if(map[i][j]==1){
							map[i][j]=0;//删除所有以该节点开始的边 
							indegree[j]--;//修改其入度 
						}
					}
					break; //每次只找一个结点
				}
			}
		} 
		if(n==count) printf("YES\n") ;
		else printf("NO\n");
	 } 
	 return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值