Cable master(二分查找)

Cable master

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31900 Accepted: 6827

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00


题意:有n段长度分别为Li的电缆,要求把它们分割成K条长度为X的电缆,问X的最大值为多少。


题解:将X视为变量,可知它的范围为0~max;  那么问题就变成了电缆长度取X时,所得的电缆条数大于,还是等于,或小于K的问题。二分

代码如下

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cmath>
    using namespace std;
    #define INF 100001
    #define maxn 10010
    double a[maxn];
    int n,k;
    bool dix(double x){
        int num = 0,i;
        for(i = 0; i < n; i++){
            num += (int)(a[i]/x);
        }//统计以x为单位长度时,所有的绳子能够分出多少个
        return num>=k;//如果分出的个数恰好够了要求的数目返回true,否则false
    }
    int main(){
        while(~scanf("%d%d",&n,&k)){
            int i;
            for(i = 0; i < n; i++){
                scanf("%lf",&a[i]);
            }
            double left = 0,right = INF,mid;
            i = 1000;
            while(i--){//1000次计算精确结果
                mid = (left+right)/2;//二分取中间
                if(dix(mid))//判断这个中间值是否能分出k个
                    left = mid;//如果可以让左边等于mid取寻找更大的
                else
                    right = mid;//如果不可以说明分的单位长度太大,
                                //右边等于中间,去找更小的来满足题意
            }
            printf("%.2f\n",floor(right*100)/100);//而right是不符合的过大的,即区间为[left,right),所以最大的为right的前面最接近right的地方
        }                                         //因此用到floor找到小于right的最大数
        return 0;
    }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值