Number Sequence (正解:矩阵快速幂)

Number Sequence

 A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5
题意:

题意很简单就是给你一个数n,让你求F(n)

分析:

网上有很多博客上写找规律,找循环节,但是当你们问他为什么这个周期是这些,却很难回答。如果它真的具有规律并具有固定周期,一定可以通过某种方法证明,只不过我们不会,但对于这个题目应该是没法证明的,看hduoj的discuss中就给了下面几组测试数据:
input
247 602 35363857
376 392 9671521
759 623 18545473
53 399 46626337
316 880 10470347
0 0 0
output
4
3
5
2
3
这几组测试数据如果是通过所谓规律AC的代码,有几个实际上是不对的

因此考虑到斐波那契数列的性质,这个题和斐波那契数列很类似,发现我们应该使用矩阵快速幂来做,矩阵很小,模板直接写。

(f(3)f(2))=(a1b0)(f(2)f(1))(161) (161) ( f ( 3 ) f ( 2 ) ) = ( a b 1 0 ) ( f ( 2 ) f ( 1 ) )

f(3)=a+b f ( 3 ) = a + b
(f(n)f(n1))=(a1b0)n2(f(2)f(1))(162) (162) ( f ( n ) f ( n − 1 ) ) = ( a b 1 0 ) n − 2 ( f ( 2 ) f ( 1 ) )

A=(a1b0)n2 A = ( a b 1 0 ) n − 2
那么 ans=(A[0][0]+A[0][1])%7 a n s = ( A [ 0 ] [ 0 ] + A [ 0 ] [ 1 ] ) % 7

但是我做这题的时候就掉进了一个坑,我的结构体写了构造函数,导致快速幂每次调用乘法的时候都会调用构造函数,导致超时。。。这回真的是记住了

code:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
struct Matrix{
    int m[2][2];
};
Matrix mul(Matrix a,Matrix b){
    Matrix ans;
    for(int i = 0; i < 2; i++){
        for(int j = 0; j < 2; j++){     
            ans.m[i][j] = 0;
            for(int k = 0; k < 2; k++){
                ans.m[i][j] = (ans.m[i][j] + a.m[i][k] * b.m[k][j] % 7) % 7;
            }

        }
    }
    return ans;
}
int main(){
    int A,B,n;
    while(scanf("%d%d%d",&A,&B,&n) != EOF){
        if(A == 0 && B == 0 && n == 0) break;
        if(n <= 2){
            printf("1\n");
            continue;
        }
        Matrix a,ans;
        a.m[0][0] = A;
        a.m[0][1] = B;
        a.m[1][0] = 1;
        a.m[1][1] = 0;
        ans.m[0][0] = ans.m[1][1] = 1;
        ans.m[0][1] = ans.m[1][0] = 0;
        n -= 2;
        while(n){
            if(n & 1)
                ans = mul(ans,a);
            n >>= 1;
            a = mul(a,a);
        }
        printf("%d\n",(ans.m[0][0] + ans.m[0][1]) % 7);
    }
    return 0;
}
  • 8
    点赞
  • 17
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值