7-15 两个有序链表序列的合并(20 分)

7-15 两个有序链表序列的合并(20 分)

已知两个非降序链表序列S1与S2,设计函数构造出S1与S2的并集新非降序链表S3。

输入格式:

输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用1表示序列的结尾(1不属于这个序列)。数字用空格间隔。

输出格式:

在一行中输出合并后新的非降序链表,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL

输入样例:

1 3 5 -1
2 4 6 8 10 -1

输出样例:

1 2 3 4 5 6 8 10

code:
 
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
//struct Node{
//    int Data;
//    struct Node* Next;
//};
//typedef struct Node* List;
int a[10000000];
int b[10000000];
int ans[10000000];//用数组代替链表小到先放到答案数组中,遍历到最后
int main(){
    int x;
    int cnta = 0,cntb = 0;
    while(~scanf("%d",&x)&&x!=-1){
        a[cnta++] = x;
    }
    while(~scanf("%d",&x)&&x!=-1){
        b[cntb++] = x;
    }
    int cnt = 0;
    int i = 0,j = 0;
    while(i!=cnta&&j!=cntb){
        if(a[i]<b[j]){
            ans[cnt++] = a[i];
            i++;
        }
        else if(a[i]>b[j]){
            ans[cnt++] = b[j];
            j++;
        }
        else{
            ans[cnt++] = a[i];
            ans[cnt++] = b[j];
            i++;
            j++;
        }
    }
    if(i!=cnta){
        while(i!=cnta){
            ans[cnt++] = a[i];
            i++;
        }
    }
    if(j!=cntb){
        while(j!=cntb){
            ans[cnt++] = b[j];
            j++;
        }
    }
    for(i = 0; i < cnt; i++){
        if(i==0){
            printf("%d",ans[i]);
        }
        else{
            printf(" %d",ans[i]);
        }
    }
    if(cnt==0)printf("NULL\n");
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值