Seek the Name, Seek the Fame (kmp)

Seek the Name, Seek the Fame


The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5
这道题很明显的是要求kmp中的next数组,但是要搞懂题意。

题目让我么求得是既是整个字符串的前缀又是后缀的,所以答案并不是next数组的每一个数。

首先字符串本身就是一个,然后求出next数组后next[len]其实就是整个字符串的前后缀最长长度,这样我们有求出一个长度,然后根据已经得到的最长的原本字符串的前后缀公共子串,我们通过i = next【i】就可以求得这个公共子串的子串,当然也是原字符串的的前后缀子串了。

code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN = 1010000;
char s[MAXN];
int Next[MAXN];
int ans[MAXN];
void getNext(){
    int i = -1,j = 0;
    int lens = strlen(s);
    Next[0] = -1;
    while(j < lens){
       if(i == -1 || s[i] == s[j]){
          i++,j++;
          Next[j] = i;
       }
       else
          i = Next[i];
    }
    return;
}
int main(){
    while(~scanf("%s",s)){
       getNext();
       int cnt = 0;
       int i;
       for(i = strlen(s); Next[i] != -1; i = Next[i]){
           ans[cnt++] = i;
       }
       printf("%d",ans[cnt-1]);
       for(i = cnt-2; i >= 0; i--){
           printf(" %d",ans[i]);
       }
       printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值