How many HDU - 2609 (最小表示法)

How many

HDU - 2609

Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.

Input
The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').
Output
For each test case output a integer , how many different necklaces.
Sample Input
4
0110
1100
1001
0011
4
1010
0101
1000
0001
Sample Output
1
2
思路:把所有字符串用最小表示法表示出来,然后全部放在vector中,然后从小到大排个序

前n个有多少个不同字符就有多少个不同串,如果前n个字符全一样说明这n个都可以表示成1个

code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
int n;
char s[101],ss[101];
int getmin(){
    int i = 0,j = 1, k = 0;
    int len = strlen(s);
    while(i < len && j < len && k < len){
        int t = s[(j+k)%len]-s[(i+k)%len];
        if(t == 0) k++;
        else{
            if(t > 0) j = j+k+1;
            else i = i+k+1;
            if(i == j) j++;
            k = 0;
        }
    }
    int ans = min(i,j);
    return ans;
}
int main(){
    int i,j,k;
    while(~scanf("%d",&n)){
        vector<string>sn;
        for(i = 0; i < n; i++){
            scanf("%s",s);
            int len = strlen(s);
            k = getmin();
            for(j = 0; j < len; j++){
                ss[j] = s[(k+j)%len];
            }
            string st(ss);
            sn.push_back(st);
        }
        sort(sn.begin(),sn.end());
        int ans = 1;
        for(i = 1; i < n; i++){
            if(sn[i] != sn[i-1])
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值