1094. The Largest Generation (25)(bfs)

1094. The Largest Generation (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
bfs层序遍历

code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
int n,m;
vector<int>G[110];
int vis[110];
struct node{
    int level;
    int id;
}s,nexts;
struct generation{
    int num;
    int level;
}g[110];
void bfs(){
    queue<node>q;
    vis[1] = 1;
    s.level = 1;
    s.id = 1;
    g[1].num = 1;
    q.push(s);
    while(!q.empty()){
        s = q.front();
        q.pop();
        for(int i = 0; i < G[s.id].size(); i++){
            if(!vis[G[s.id][i]]){
                vis[G[s.id][i]] = 1;
                nexts.id = G[s.id][i];
                nexts.level = s.level + 1;
                g[nexts.level].num++;
                q.push(nexts);
            }
        }
    }
}
bool cmp(generation a,generation b){
    return a.num > b.num;
}
int main(){
    int i,j;
    for(i = 0; i < 110; i++){
        g[i].level = i;
        g[i].num = 0;
    }
    cin >> n >> m;
    for(i = 0; i < m; i++){
        int id,k,son;
        cin >> id >> k;
        for(j = 0; j < k; j++){
            cin >> son;
            G[id].push_back(son);
        }
    }
    memset(vis,0,sizeof(vis));
    bfs();
    sort(g+1,g+1+n,cmp);
    cout << g[1].num << " " << g[1].level << endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
在您提供的示例中,图片的URL是 `https://i0.hdslb.com/bfs/bangumi/image/3c74d1bf9c15c200167a3c0bcdcd11221e3c8a7a.png@220w_280h.webp`。 有几个可能导致该图片无法加载的原因: 1. 错误的URL:请确保URL是正确的,并且没有任何拼写错误或缺失部。 2. 服务器问题:检查服务器是否正常运行,并且可以提供所请求的文件。如果服务器发生故障或配置有误,可能会导致图片无法加载。 3. 跨域问题:如果您的网页与图片的域不同,并且服务器没有配置正确的跨域资源共享(CORS),则浏览器会阻止加载该图片。您可以尝试使用服务器代理或将图片上传到与您的网页相同的域。 4. 图片格式问题:请确保图片文件格式正确。在您提供的示例中,图片的URL末尾似乎包含了 `@220w_280h.webp`,这可能是为了指定图片的宽度和高度,但这不是标准的URL格式。请尝试删除这部并重新加载图片。 5. 网络问题:检查您的网络连接是否正常。如果网络连接不稳定或中断,可能会导致图片无法加载。 6. 浏览器问题:某些浏览器可能对特定格式(如WebP)的图片支持有限。请确保您使用的浏览器支持WebP格式,或者尝试将图片转换为其他常见的图片格式(如JPEG或PNG)。 如果您仍然无法加载图片,请逐步检查上述原因,并尝试解决问题。您还可以在浏览器的开发者工具中查看错误消息,以获取更多关于加载失败的详细信息。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值