Knapsack problem FZU - 2214 (01背包变形)

Knapsack problem

FZU - 2214

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).


Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

Output

For each test case, output the maximum value.

Sample Input
1
5 15
12 4
2 2
1 1
4 10
1 2
Sample Output
15

我们用dp针对不同的价值计算最小的重量

当时想到了这样转变就是不知道怎么初始化了结果就没做出来哎

初始化为INF表示不存在而且由于前0个物品中什么都挑选不了,所以初始化dp[0] = 0;

code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int INF = 0x3f3f3f3f;
int v[1010],w[1010];
int dp[5050];//dp[i]表示价值为i时的最小重量
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n,W;
        scanf("%d%d",&n,&W);
        int V = 0;
        for(int i = 0; i < n; i++){
            scanf("%d%d",&w[i],&v[i]);
            V += v[i];
        }
        //初始化(很重要!)
        memset(dp,INF,sizeof(dp));
        dp[0] = 0;
        for(int i = 0; i < n; i++){
            for(int j = V; j >= v[i]; j--){
                dp[j] = min(dp[j],dp[j-v[i]]+w[i]);
            }
        }
        for(int i = V; i >= 0; i--){
            if(dp[i] <= W){
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值