Harmonic Number (II) LightOJ - 1245 (找规律+数学)

Harmonic Number (II)

LightOJ - 1245

I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
   
 long long res = 0;
   
 for( int i = 1; i <= n; i++ )
        res
 = res + n / i;
   
 return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.


Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386


题意:题目很简单让你求n/1+n/2+……+n/n;

思路:其实这道题和数论没有太多关系,就是一个找规律的题目,一开始我观察这个公式是n(1+1/2+1/3+……+1/n)以为会有一个求和公式,结果它是一个调和级数,不收敛,虽然有一个近似公式约等于欧拉常数+ln(n)但是只能在n趋近于无穷的时候无限逼近,所以只能找其中的规律

先求出前sqrt(n)项和:即n/1+n/2+...+n/sqrt(n)

再求出后面所以项之和.后面每一项的值小于或者等于sqrt(n),计算值为1到sqrt(n)的项的个数,乘以其项值即可快速得到答案

例如:10/1+10/2+10/3+...+10/10

sqrt(10) = 3

先求出其前三项的和为10/1+10/2+10/3

在求出值为1的项的个数为(10/1-10/2)个,分别是(10/10,10/9,10/8,10/7,10/6),值为2个项的个数(10/2-10/3)分别是(10/5,10/4),在求出值为3即sqrt(10)的项的个数.

显然,值为sqrt(10)的项计算了2次,减去一次即可得到答案。当n/(int)sqrt(n) == (int)sqrt(n)时,值为sqrt(n)的值会被计算2次。

但是对于n=12,就不需要减,每一个值都被计算了一次

12/1+12/2+12/3+12/4+12/5+12/6+12/7+12/8+12/9+12/10+12/11+12/12

                                 3            2                                            1

                                          12/3-12/4个  12/2-12/3个                                                   12/1-12/2个


code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
int main(){
    int t,n,i;
    int cas = 0;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        long long ans = 0;
        for(i = 1; i <= (int)sqrt(n); i++){
            ans += n / i;
            if(n / i > n / (i + 1))
                ans += (long long)( ( (n / i) - (n / (i + 1)) ) * i);
        }
        i--;
        if(n / i == i)
            ans -= i;
        printf("Case %d: %lld\n",++cas,ans);
    }
    return 0;
}

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值