Anniversary party(树形dp)

Anniversary party

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0 Output Output should contain the maximal sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5

题意:一棵树,每个节点都有一个值,要选出一些点使得这些值最大,要求父亲和孩子节点不能同时选,只能出现一个。

思路:当前节点为i,dp[i][0]为i不出席时的最大快乐值,dp[i][1]为i出席时的最大快乐值。i的儿子集合(直接下属集合)为son={s1,s2,···},则有
(1)求解dp[i][0]:
for each si in son
    dp[i][0] += max(dp[si][0], dp[si][1]);
解释:i不出席时,i的儿子既可以出席也可以不出席,取快乐值最大的方案。
(2)求解dp[i][1]:
for each si in son
    dp[i][1] += dp[si][0];
解释:i出席,则i的所有儿子只能不出席。

code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
const int maxn = 6002;
struct maxVal{
    int x,y;
    //x代表自己不出席时最大值
    //y代表自己出席时的最大值
}dp[maxn];
vector<int> G[maxn];//邻接表存树
bool isroot[maxn];//判断根节点
maxVal dfs(int v){
    if(G[v].empty()){
        return dp[v];
    }
    for(int i = 0; i < G[v].size(); i++){
        maxVal val = dfs(G[v][i]);
        dp[v].x += max(val.x,val.y);//v不出席,儿子可以出席可以不出席,加上儿子的值最大的
        dp[v].y += val.x;//v出席,儿子只能不出席
    }
    return dp[v];
}
int main(){
    int n,root;
    while(scanf("%d",&n) != EOF){
        for(int i = 1; i <= n; i++){
            scanf("%d",&dp[i].y);
            dp[i].x = 0;
            isroot[i] = true;
            G[i].clear();
        }
        int l,k;
        while(scanf("%d%d",&l,&k) && l){
            G[k].push_back(l);
            isroot[l] = false;
        }
        //找根
        for(int i = 1; i <= n; i++){
            if(isroot[i]){
                root = i;
                break;
            }
        }
        maxVal ans = dfs(root);
        printf("%d\n",max(ans.x,ans.y));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值