素数环——Prime Ring Problem

Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 

Input

n (0 < n < 20). 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

个人觉得这道题用作dfs入门训练比较合适,比八皇后稍微好理解一点吧;

搜索题没有固定的模板,代码也不是一步就写好的,所以大致思路明白然后慢慢改就行了。。。。逃

#include<set>
#include<queue>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
const int maxn=1000005;
int ans[30];
int vis[30];
bool isprime(int n)//判断素数
{
    for(int i=2;i<n;i++)
        if(n%i==0) return false;
    return true;
}
int n;
void print()//输出结果
{
    for(int i=1;i<=n;i++)
        {
            cout<<ans[i];
            if(i==n) cout<<endl;
            else cout<<' ';
        }
}
void dfs(int k,int rt)
{
    if(rt==n&&isprime(k+ans[1]))//dfs的特点,一进来就判断是否return,判断返回的条件
    //位置已经放到第n个了并且当前这个与第一个放的之和不是素数
    {
        print();
        return ;
    }
    vis[k]=1;
    ans[rt]=k;//记录答案
    for(int i=1;i<=n;i++)
        if(!vis[i]&&isprime(i+k))//当前搜到的数是否符合要求
    {
        ans[rt+1]=i;//记录答案
        vis[i]=1;//标记已经访问
        dfs(i,rt+1);
        vis[i]=0;   //把搜过的点置为0,因为要搜出所有符合的结果
    }

}
int main()
{
    int cnt=1;
    while(scanf("%d",&n)!=EOF)
    {
        memset(ans,0,sizeof ans);
        memset(vis,0,sizeof vis);
        cout<<"Case "<<cnt++<<':'<<endl;
        dfs(1,1);
        cout<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
素数问题是一种经典的组合数学问题,其描述如下: 给定一个正整数 n,找到长度为 n 的形排列,使得相邻两个数之和均为素数。同一个数字不能被重复使用。 解决素数问题的一种常见方法是使用回溯法。具体地,我们可以定义一个长度为 n 的数组 arr,表示当前已经排列好的数字序列。我们从数字 1 开始,依次尝试将它放到 arr[0] 的位置,然后递归搜索下一个数字。如果当前数字无法满足相邻两个数之和为素数的条件,我们就回溯到上一个数字,继续尝试下一个可行的位置。 为了判断两个数字之和是否为素数,我们可以使用一个预处理表格,将所有可能的素数先计算出来,然后在回溯过程中直接查表即可。 下面是一个简单的 Python 代码实现: ```python def is_prime(n): if n < 2: return False for i in range(2, int(n ** 0.5) + 1): if n % i == 0: return False return True def solve_prime_ring(n): arr = [0] * n primes = [i for i in range(2, 2 * n) if is_prime(i)] def backtrack(k): if k == n: if is_prime(arr[0] + arr[n-1]): print(arr) return for i in range(1, n): if i not in arr and is_prime(i + arr[k-1]): arr[k] = i backtrack(k+1) arr[k] = 0 arr[0] = 1 backtrack(1) solve_prime_ring(5) ``` 这里的 is_prime 函数用来判断一个数是否为素数primes 则是一个预处理的素数表格。在回溯函数 backtrack 中,我们依次尝试将数字 1 到 n-1 放到 arr[k] 的位置,只有当该数字还未被使用且与前一个数字之和为素数时,才递归搜索下一个数字。当搜索到第 n 个数字时,如果第一个数字与最后一个数字之和为素数,则打印出当前符合要求的排列,否则回溯到上一个数字继续尝试。最终,程序会输出所有符合条件的素数
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值