ZOJ2969 Easy Task java

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2969

                                           Easy Task

Calculating the derivation of a polynomial is an easy task. Given a function f(x) , we use (f(x))' to denote its derivation. We use x^n to denote xn. To calculate the derivation of a polynomial, you should know 3 rules: 
(1) (C)'=0 where C is a constant. 
(2) (Cx^n)'=C*n*x^(n-1) where n>=1 and C is a constant. 
(3) (f1(x)+f2(x))'=(f1(x))'+(f2(x))'. 

It is easy to prove that the derivation a polynomial is also a polynomial.

Here comes the problem, given a polynomial f(x) with non-negative coefficients, can you write a program to calculate the derivation of it?

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 1000) which is the number of test cases. And it will be followed by T consecutive test cases.

There are exactly 2 lines in each test case. The first line of each test case is a single line containing an integer N (0 <= N <= 100). The second line contains N + 1 non-negative integers, CNCN-1, ..., C1C0, ( 0 <= Ci <= 1000), which are the coefficients of f(x). Ci is the coefficient of the term with degree i in f(x). (CN!=0)

Output

For each test case calculate the result polynomial g(x) also in a single line. 
(1) If g(x) = 0 just output integer 0.otherwise 
(2) suppose g(x)= Cmx^m+Cm-1x^(m-1)+...+C0 (Cm!=0),then output the integers Cm,Cm-1,...C0.
(3) There is a single space between two integers but no spaces after the last integer. 

Sample Input

3

0

10

2

3   2   1

3

10   0   1   2

Sample Output

0

6   2

30   0   1

题意:

求多项式的导数的系数。每个测试用例中都有2行。每个测试用例的第一行是包含整数 N (0 = N = 100) 的单行。第二行包含 N + 1 非负整数, CN, CN-1,.., C1, C0, 这是 f (x) 的系数。如题目例子,N为2,第二行为3 2 1,可表示为数学表达式3x^2+2x^1+1x^0=6^x+2+0;

所以输出6 2.

思路:

导数的定义。

代码:

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			int t=sc.nextInt();
			for(int i=0;i<t;i++){
				int n=sc.nextInt();
				int[] a=new int[n+1];
				int k=n;
				for(int j=n;j>=0;j--){
					a[j]=sc.nextInt();
				}
				if(k==0){
					System.out.print(0);
				}
				while(k!=0){
					System.out.print(a[k]*k);
					if(k!=1){
						System.out.print(" ");
					}
					k--;
				}
				System.out.println();
			}
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值