Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

通过打表找规律,连续出现两次1就证明走了一个周期,f[n]肯定是一个0~6的数,所以总共有7*7=49种情况,开一个50的数组打表,找到周期对n取余。

C

#include <stdio.h>
#pragma warning(disable:4996)
int main(void)
{
	int s[50]={0,1,1},a,b,n,i;
	while(scanf("%d %d %d",&a,&b,&n)&&(a||b||n))
	{
		for(i=3;i<50;i++)
		{
			s[i]=(a*s[i-1]+b*s[i-2])%7;
			if(s[i]==1&&s[i-1]==1)
				break;
		}
		s[0]=s[i-2];
		n%=i-2;
		printf("%d\n",s[n]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值