Saruman's Army

Description
Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.
Input
The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.
Output
For each test case, print a single integer indicating the minimum number of palantirs needed.
Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output
2 4

思路:贪心法。我们从最左边开始考虑。对于这个点,到距其r以内的区域内必须带有标记的点。带有标记的这个点显然在此点的右侧,我们应该从最左边的点开始加上标记,因为更左的区域没有覆盖的意义,所以尽可能覆盖更靠右的点。p点就是被标记的点,剩下的部分同样这么处理,找到其右侧r距离以内最远的点添加标记。
这里写图片描述

import java.util.Arrays;
import java.util.Scanner;

public class SarumanArmy {

    public static void main(String[] args){
        Scanner in=new Scanner(System.in);
        while (in.hasNext()) {
            int r=in.nextInt();
            int n=in.nextInt();
            int arr[]=new int[n];
            for (int i = 0; i < arr.length; i++) {
                arr[i]=in.nextInt();
            }
            Arrays.sort(arr);
            int i=0,ans=0;
            while (i<n) {
                int s=arr[i++];
                while(i<n && arr[i]<=s+r) {
                    i++;
                }
                int p=arr[i-1];
                while (i<n && arr[i]<=p+r) {
                    i++;
                }
                ans++;
            }
            System.out.println(ans);
        }
        // TODO Auto-generated method stub

    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值