ZOJ Problem Set - 3543 Number String DP

Number String

Time Limit: 5 Seconds      Memory Limit: 65536 KB

The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of lengthn that contains each of the integers 1 throughn exactly once.

Input

Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.

Output

For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.

Sample Input
II
ID
DI
DD
?D
??
Sample Output
1
2
2
1
3
6
Hint

Permutation {1,2,3} has signature "II".
Permutations {1,3,2} and {2,3,1} have signature "ID".
Permutations {3,1,2} and {2,1,3} have signature "DI".
Permutation {3,2,1} has signature "DD".
"?D" can be either "ID" or "DD".
"??" gives all possible permutations of length 3.

  一个长度n的排列(数为1-n),I表示后一个数比前一个大,D表示后一个数比前一个小,?表示随意。有多少种排列方法。

  dp[i][j]表示长度为i的排列最后一个数是j并且满足前i-1个关系的有多少种。当前循环到第i位,这一位取j,如果关系是I,那么dp[i][j]=sum(dp[i-1][k],1<=k<j),如果关系是D,dp[i][j]=sum(dp[i-1][k],j<=k<=i-1),k可以取到j是因为之前的取值大于等于j的都相对加了1,也就是k==j时得到的新排列倒数第二位是j+1>j。如果关系是?那就任何情况都满足了,dp[i][j]=sum(dp[i-1][k],1<=k<=i-1)。sum存下来的话可以少一层循环,复杂度O(N^2)。

#include<cstring>
#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;

typedef long long LL;

const int MAXN=1010;
const LL MOD= 1000000007;

LL dp[MAXN][MAXN],sum[MAXN][MAXN];
char str[MAXN];

int main(){
    freopen("in.txt","r",stdin);
    while(scanf("%s",str+1)!=EOF){
        int len=strlen(str+1);
        memset(dp,0,sizeof(dp));
        memset(sum,0,sizeof(sum));
        dp[1][1]=1;
        sum[1][1]=1;
        for(int i=1;i<=len;i++)
            for(int j=1;j<=i+1;j++){
                if(str[i]=='I') dp[i+1][j]=sum[i][j-1];
                else if(str[i]=='D') dp[i+1][j]=(sum[i][i]-sum[i][j-1]+MOD)%MOD;
                else dp[i+1][j]=sum[i][i];
                sum[i+1][j]=(sum[i+1][j-1]+dp[i+1][j])%MOD;
            }
        printf("%lld\n",sum[len+1][len+1]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值