hdu3586 Information Disturbing 树形DP

Information Disturbing

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 2060    Accepted Submission(s): 751


Problem Description
In the battlefield , an effective way to defeat enemies is to break their communication system.
The information department told you that there are n enemy soldiers and their network which have n-1 communication routes can cover all of their soldiers. Information can exchange between any two soldiers by the communication routes. The number 1 soldier is the total commander and other soldiers who have only one neighbour is the frontline soldier.
Your boss zzn ordered you to cut off some routes to make any frontline soldiers in the network cannot reflect the information they collect from the battlefield to the total commander( number 1 soldier).
There is a kind of device who can choose some routes to cut off . But the cost (w) of any route you choose to cut off can’t be more than the device’s upper limit power. And the sum of the cost can’t be more than the device’s life m.
Now please minimize the upper limit power of your device to finish your task.
 

Input
The input consists of several test cases.
The first line of each test case contains 2 integers: n(n<=1000)m(m<=1000000).
Each of the following N-1 lines is of the form:
ai bi wi
It means there’s one route from ai to bi(undirected) and it takes wi cost to cut off the route with the device.
(1<=ai,bi<=n,1<=wi<=1000)
The input ends with n=m=0.
 

Output
Each case should output one integer, the minimal possible upper limit power of your device to finish your task.
If there is no way to finish the task, output -1.
 

Sample Input
  
  
5 5 1 3 2 1 4 3 3 5 5 4 2 6 0 0
 

Sample Output
  
  
3

  要切断根结点和所有叶子结点的联系,切断的边的权值不能大于一个上限,切断边的权值和不能大于M。求这个上限最小是多少。

  二分上限limit,dp[u]代表切断u和它这棵树所有叶子联系最小要切断的权值和,dp2[u]代表切断u和它这棵树所有叶子联系在权值和最小的情况下最大的一条边权值,dp和dp2都是在满足所有切断边权都不大于limit的情况下,初始化为INF,如果求完仍为INF说明不可能在这个limit下把所有叶子隔断。如果dp[1]<=M就说明是满足的,把这个做为二分的条件。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
typedef long long LL;

const LL MAXN=1010;
const LL MAXM=15;
const LL INF=0x3f3f3f3f;

int N,M;
int dp[MAXN],dp2[MAXN];
vector<pair<int,int> > g[MAXN];

void dfs(int u,int fa,int limit){
    int len=g[u].size();
    if(len<=1&&g[u][0].first==fa) return;
    int flag=0,sum=0,m=0;
    for(int i=0;i<len;i++){
        int v=g[u][i].first;
        if(v!=fa){
            dfs(v,u,limit);
            int tmp=min(g[u][i].second,dp2[v]);
            if(tmp>limit) flag=1;
            else{
                sum+=tmp;
                m=max(m,tmp);
            }
        }
    }
    if(!flag){
        dp[u]=sum;
        dp2[u]=m;
    }
}

int main(){
    freopen("in.txt", "r", stdin);
    while(scanf("%d%d",&N,&M)!=EOF&&(N||M)){
        for(int i=1;i<=N;i++) g[i].clear();
        int u,v,w;
        for(int i=0;i<N-1;i++){
            scanf("%d%d%d",&u,&v,&w);
            g[u].push_back(make_pair(v,w));
            g[v].push_back(make_pair(u,w));
        }
        if(N<=1){
            printf("0\n");
            continue;
        }
        int l=0,r=1001;
        while(l<r){
            int mid=l+(r-l)/2;
            memset(dp,INF,sizeof(dp));
            memset(dp2,INF,sizeof(dp2));
            dfs(1,-1,mid);
            if(dp[1]>M) l=mid+1;
            else r=mid;
        }
        if(r!=1001) printf("%d\n",l);
        else printf("-1\n");
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值