6581 Number Triangle

6581 Number Triangle

时间限制:500MS  内存限制:1000K
提交次数:57 通过次数:47

题型: 编程题   语言: G++;GCC

Description

        7
      3   8
    8   1   0
  2   7   4   4
4   5   2   6   5
   (Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 


输入格式

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. 
The following N lines describe the data of the triangle. The number of rows in the triangle is &gt; 1 but <= 100. 
The numbers in the triangle, all integers, are between 0 and 99. 


输出格式

Your program is to write to standard output. The highest sum is written as an integer.


输入样例

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5


输出样例

30



 //注意点: 数据较多,数据类型 必须用 Long long  且最好不要用 cout; 

//         第三个case 用cin>>  因为ctrl+x可以结束cin>>输入;
//求路径最长 可以从底部 往上求最优解
//从共 N行的三角形    从N-1行开始 T[N-1][1] 的最优解是 T[N][1]和T[N][2]中大的加上T[N-1][1]
//依次这样 从T[N-1][1]~~T[N-1][N-1] 再从第N-1行到第一行  每次都是看这个点下面的两个点谁大 加上谁
//最后 到 T[1][1]时  就是最优解;
#include <iostream>
#include <cstdio>
#include <cstdlib>
using namespace std;

int main()
{
    int n;  cin>>n;//三角形行数
    int T[n+1][n+1] ;
    for(int i=1;i<=n;i++)
    for(int j=1;j<=i;j++)
        cin>>T[i][j];   //构造三角形
    for(int i=n-1;i>=1;i--)
    for(int j=1;j<=i;j++)
    {
        T[i][j]+=T[i+1][j]>T[i+1][j+1]? T[i+1][j]:T[i+1][j+1];//看该点下面的两个点 谁大;
    }
    cout<<T[1][1]<<endl;//最优解
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值