HDOJ1161. Eddy's mistakes(字符串处理)

一道关于字符串处理的基础题目,要求将包含空格、字母和数字的多组输入字符串中所有大写字母转换成小写字母。输入处理时应注意使用gets(str)读取含空格的字符串。
摘要由CSDN通过智能技术生成

Eddy's mistakes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12441    Accepted Submission(s): 6997


Problem Description
Eddy usually writes articles ,but he likes mixing the English letter uses, for example "computer science" is written frequently "coMpUtEr scIeNce" by him, this mistakes lets Eddy's English teacher be extremely discontentment.Now please you to write a procedure to be able in the Bob article English letter to turn completely the small letter.
 

Input
The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation
composition, the writing length does not surpass 1000 characters.
 

Output
For each test case, you should output an only line, after namely the result of transforms the lowercase letter.
 

Sample Input
 
 
weLcOmE tO HDOj Acm 2005!
 

Sample Output
 
 
welcome to hdoj acm 2005!

【分析】字符串处理

        题意:多组输入,输入字符串(含空格、字母、数字),将其中的大写字母转为小写字母。

        基础题,需要注意含空格的字符串str用 gets(str); 读入。

#include <stdio.h>
#include <string.h>
#define maxlen 1010 
char str[maxlen];
int main()
{
	int i,len;
	while(gets(str))
	{
		len=strlen(str);
		for(i=0;i<len;i++)
		{
			if(str[i]>='A' && str[i]<='Z')
				str[i]+=32;
		}
		puts(str);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值