Eddy's mistakes
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12441 Accepted Submission(s): 6997
Problem Description
Eddy usually writes articles ,but he likes mixing the English letter uses, for example "computer science" is written frequently "coMpUtEr scIeNce" by him, this mistakes lets Eddy's English teacher be extremely discontentment.Now please you to write a procedure to be able in the Bob article English letter to turn completely the small letter.
Input
The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation
composition, the writing length does not surpass 1000 characters.
composition, the writing length does not surpass 1000 characters.
Output
For each test case, you should output an only line, after namely the result of transforms the lowercase letter.
Sample Input
weLcOmE tO HDOj Acm 2005!
Sample Output
welcome to hdoj acm 2005!
【分析】字符串处理
题意:多组输入,输入字符串(含空格、字母、数字),将其中的大写字母转为小写字母。
基础题,需要注意含空格的字符串str用 gets(str); 读入。
#include <stdio.h>
#include <string.h>
#define maxlen 1010
char str[maxlen];
int main()
{
int i,len;
while(gets(str))
{
len=strlen(str);
for(i=0;i<len;i++)
{
if(str[i]>='A' && str[i]<='Z')
str[i]+=32;
}
puts(str);
}
return 0;
}