hdu4027 线段树单点更新

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 14924 Accepted Submission(s): 3502

Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output
Case #1:
19
7
6

Source
The 36th ACM/ICPC Asia Regional Shanghai Site —— Online Contest

题意:给你n个数,两种操作,第一种修改区间中每一个数为这个数的开平方根取整,第二种操作是询问区间和。

解题思路:刚开始一看以为是区间更新,但是这个不同于一般的区间更新,这个是区间中的每个数开平方根,所以比较难进行区间更新,我们发现,一个数若是一直进行开方,则几次之后就会变成1,所有我们可以进行单点更新,若是区间每个数都变成了1我们就可以不更新了,判断的方法就是先询问一次区间和,若是区间和等于区间长度则区间中的每个数都是1,特别要注意,这题题目没有说X,Y的大小关系,要比较一下,我在这里RE了很多次。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e6 + 10;
int n,m;
ll a[maxn];
int father[maxn];
struct node{
    int l;
    int r;
    ll sum;
}Node[maxn*8];
void build(int i,int l,int r)
{
    Node[i].sum = 0;
    Node[i].l = l;
    Node[i].r = r;
    if(l == r)
    {
        father[l] = i;
        return;
    }
    int mid = (l + r)>>1;
    i <<= 1;
    build(i,l,mid);
    build(i + 1,mid + 1,r);
}
void update(int i)
{
    if(i == 1) return;
    int f = i>>1;
    int lson = f<<1;
    int rson = lson + 1;
    Node[f].sum = Node[lson].sum + Node[rson].sum;
    update(f);
}
ll query(int i,int l,int r)
{
    if(Node[i].l == l&&Node[i].r == r) return Node[i].sum;
    int lson = i<<1;
    int rson = lson + 1;
    if(r <= Node[lson].r) return query(lson,l,r);
    else if(l >= Node[rson].l) return query(rson,l,r);
    else return query(lson,l,Node[lson].r) + query(rson,Node[rson].l,r);
}
int main()
{
    int Case = 1;
    while(~scanf("%d",&n))
    {
        build(1,1,n);
        for(int i = 1; i <= n; i++)
        {
            scanf("%I64d",&a[i]);
            Node[father[i]].sum = a[i];
            update(father[i]);
        }
        scanf("%d",&m);
        int t,x,y;
        printf("Case #%d:\n",Case++);
        while(m--)
        {
            scanf("%d%d%d",&t,&x,&y);
            if(x > y)
            swap(x,y);
            if(t == 0)
            {
                ll ans = query(1,x,y);
                if(ans == ll(y - x + 1))
                {
                    continue;
                }
                else
                {
                    for(int i = x; i <= y; i++)
                    {
                        ll term = (ll)sqrt(a[i]);
                        Node[father[i]].sum = term;
                        a[i] = term;
                        update(father[i]);
                    }
                }
            }
            else
            {
                printf("%I64d\n",query(1,x,y));
            }
        }
        printf("\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值