POJ 3252 Round Numbers 排列组合(难)

Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7979 Accepted: 2769

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6

Source



题意是说如果一个数的二进制数中0的个数大于等于1的个数,那么这个数字就是Round Numbers,给你两个数,让你在他们之间求有多少个Round Numbers。
表示排列组合太难推了,看了一篇好的解题报告才明白点击打开链接
#include<stdio.h>
#define M 31
int c[M][M],power2[M],binary[M];
int solve(int x)
{
    int i,j,k,n0,n1,len,res=0;
    if(x<=1)return 0;
    for(i=0;i<M;i++){binary[i]=((power2[i]&x)!=0)?1:0;}
    for(i=M-1;i>=0&&binary[i]==0;i--);
    for(len=i;len>=1;len--)
    {
        if(len%2==1)res+=((power2[len-1]-c[len-1][(len-1)/2])>>1);
        else res+=(power2[len-1]>>1);
    }
    for(j=i,n0=0,n1=0;j>=0;j--)
        if(binary[j])n1++;
        else n0++;
    if(n0>=n1)res++;
    for(j=i-1,n0=0,n1=1;j>=0;j--)
        if(binary[j])
        {
            for(k=j;k>=0&&k+n0+1>=j-k+n1;k--)
                res+=c[j][k];
            n1++;
        }
        else n0++;
    return res;

}
int main()
{
    for(int i=0;i<M;i++){c[i][0]=1,c[i][i]=1,power2[i]=(1<<i);}
    for(int i=2;i<M;i++)
        for(int j=1;j<i;j++)
            c[i][j]=c[i-1][j-1]+c[i-1][j];
    int s,t;
    scanf("%d%d",&s,&t);
        printf("%d\n",solve(t)-solve(s-1));
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值