HDU 4961 Boring Sum 打表、更新

Boring Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 715    Accepted Submission(s): 351


Problem Description
Number theory is interesting, while this problem is boring.

Here is the problem. Given an integer sequence a 1, a 2, …, a n, let S(i) = {j|1<=j<i, and a j is a multiple of a i}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as a f(i). Similarly, let T(i) = {j|i<j<=n, and a j is a multiple of a i}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define c i as a g(i). The boring sum of this sequence is defined as b 1 * c 1 + b 2 * c 2 + … + b n * c n.

Given an integer sequence, your task is to calculate its boring sum.
 

Input
The input contains multiple test cases.

Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a 1, a 2, …, a n (1<= a i<=100000).

The input is terminated by n = 0.
 

Output
Output the answer in a line.
 

Sample Input
   
   
5 1 4 2 3 9 0
 

Sample Output
   
   
136
Hint
In the sample, b1=1, c1=4, b2=4, c2=4, b3=4, c3=2, b4=3, c4=9, b5=9, c5=9, so b1 * c1 + b2 * c2 + … + b5 * c5 = 136.
 

Author
SYSU
 

Source
 
对于输入的数列,从前往后扫一遍,对于每个数都要更新为距离它左边最近的倍数的值,如果没有则为次数。同样从后往前扫一遍,对于每个数都要更新为距离它右边最近的倍数的值,如果没有也为次数。
将所有数的约数打个表存起来,然后扫两遍分别记录b[]和c[],扫的过程中要随时更新。
//203MS	8904K
#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
vector<int>v[100007];
int a[100007],b[100007],c[100007],vis[100007];
int main()
{
    int n;
    for(int i=2;i<100007;i++)
    {
        for(int j=i;j<100007;j+=i)
            v[j].push_back(i);
    }
    while(scanf("%d",&n),n)
    {
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)
        {
             if(!vis[a[i]])b[i]=a[i];
             else b[i]=vis[a[i]];
             vis[1]=a[i];          //因为打表的时候没有算上约数1,所以要加上
             for(int j=0;j<v[a[i]].size();j++)//更新a[i]的约数
                 vis[v[a[i]][j]]=a[i];
        }
        memset(vis,0,sizeof(vis));
        for(int i=n;i>=1;i--)
        {
             if(!vis[a[i]])c[i]=a[i];
             else c[i]=vis[a[i]];
             vis[1]=a[i];
             for(int j=0;j<v[a[i]].size();j++)
                 vis[v[a[i]][j]]=a[i];
        }
        __int64 ans=0;
        for(int i=1;i<=n;i++)
            ans+=(__int64)b[i]*(__int64)c[i];
        printf("%I64d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值