Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 8325 | Accepted: 3934 |
Description
Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.
The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.
Input
Line 2: L characters (followed by a newline, of course): the received message
Lines 3.. W+2: The cows' dictionary, one word per line
Output
Sample Input
6 10 browndcodw cow milk white black brown farmer
Sample Output
2
Source
//160K 0MS
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[1007];
char s[307];
struct S
{
char word[27];//单词
int len;//单词长度
char lastword;//单词最后一个元素
}p[607];
int main()
{
int n,len;
while(scanf("%d%d",&n,&len)!=EOF)
{
scanf("%s",s+1);
for(int i=0;i<n;i++)
{
scanf("%s",p[i].word);
p[i].len=strlen(p[i].word);
p[i].lastword=p[i].word[p[i].len-1];
}
memset(dp,0,sizeof(dp));
for(int i=1;i<=len;i++)
{
dp[i]=dp[i-1]+1;//每向后移动就+1
for(int j=0;j<n;j++)
if(p[j].lastword==s[i]&&i>=p[j].len)//如果模板串第i个位置元素等于第j个单词最后的元素且i比此单词长度要长
{
int differ=0,x=i,flag=0;
for(int k=p[j].len-1;x>=1;x--)
if(p[j].word[k]==s[x])
{
k--;
if(k<0){flag=1;break;}//k<0说明此单词全部匹配完
}
else differ++;//在匹配过程中,不相等 的元素个数
if(flag)dp[i]=min(dp[i],dp[x-1]+differ);
}
}
printf("%d\n",dp[len]);
}
return 0;
}