1070. Mooncake (25)
Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.
Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.
Sample Input:3 200 180 150 100 7.5 7.2 4.5Sample Output:
9.45
注意点:由于此题的单位都比较大,所以有个坑。注意区别上面加粗标红的两句话的区别。即输入的第一行的两个数3和200都是整数,但是第二行的数不一定是整数。若不注意会有一个点过不去
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;
struct node
{
double num;
double all;
double p;
}T[1005];
bool cmp(node a,node b)
{
return a.p > b.p;
}
int main()
{
// freopen("in.txt","r",stdin);
int N;
double M;
scanf("%d %lf",&N,&M);
for(int i=0;i<N;i++)
scanf("%lf",&T[i].num);
for(int i=0;i<N;i++)
{
scanf("%lf",&T[i].all);
T[i].p=T[i].all/T[i].num;
}
sort(T,T+N,cmp);
double profit=0;
for(int i=0;i<N;i++)
{
if(T[i].num<M)
{
profit+=T[i].all;
M-=T[i].num;
}
else
{
profit+=T[i].all*M/T[i].num;
break;
}
}
printf("%.2f",profit);
return 0;
}