A Simple Problem with Integers||POJ3468

link:http://poj.org/problem?id=3468
Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

树状数组天生用来动态维护数组前缀和,其特点是每次更新一个元素的值,查询只能查数组的前缀和,但这个题目求的是某一区间的数组和,而且要支持批量更新某一区间内元素的值,怎么办呢?实际上,还是可以把问题转化为求数组的前缀和。

首先,看更新操作update(s, t, d)把区间A[s]…A[t]都增加d,我们引入一个数组delta[i],表示A[i]…A[n]的共同增量,n是数组的大小。那么update操作可以转化为:
令delta[s] = delta[s] + d,表示将A[s]…A[n]同时增加d,但这样A[t+1]…A[n]就多加了d,所以再令delta[t+1] = delta[t+1] - d,表示将A[t+1]…A[n]同时减d然后来看查询操作query(s, t),求A[s]…A[t]的区间和,转化为求前缀和,设sum[i] = A[1]+…+A[i],则A[s]+…+A[t] = sum[t] - sum[s-1],那么前缀和sum[x]又如何求呢?它由两部分组成,一是数组的原始和,二是该区间内的累计增量和, 把数组A的原始值保存在数组org中,并且delta[i]对sum[x]的贡献值为delta[i]*(x+1-i),那么
sum[x] = org[1]+…+org[x] + delta[1]x + delta[2](x-1) + delta[3](x-2)+…+delta[x]*1= org[1]+…+org[x] + segma(delta[i](x+1-i))= segma(org[i]) + (x+1)*segma(delta[i]) - segma(delta[i]*i),1 <= i <= x
这其实就是三个数组org[i], delta[i]和delta[i]*i的前缀和,org[i]的前缀和保持不变,事先就可以求出来,delta[i]和delta[i]*i的前缀和是不断变化的,可以用两个树状数组来维护。

这是区间和的模板题
AC代码:

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
long long a1[100010],a2[100010],a3[100010];
int n;
void update(long long *a,int x,int y)
{
    while(x<=n)
    {
        a[x]+=y;
        x+=(x&-x);
    }
}
long long query(long long *a,int x)
{
    long long sum=0;
    while(x>0)
    {
        sum+=a[x];
        x-=(x&-x);
    }
    return sum;
}
int main()
{
    int i,m,a,b,c,x;
    char s;
    long long ans; 
    memset(a3,0,sizeof(a3));
    scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++)
    {
        scanf("%d",&x);
        a3[i]=a3[i-1]+x;
    }
    while(m--)
    {
        scanf("%s",&s);
        if(s=='Q')
        {
            scanf("%d%d",&a,&b);
            ans=a3[b]-a3[a-1];
            ans+=(b+1)*query(a1,b)-query(a2,b);
            ans-=a*query(a1,a-1)-query(a2,a-1);
            printf("%lld\n",ans);
        }
        else
        {
            scanf("%d%d%d",&a,&b,&c);
            update(a1,a,c);
            update(a1,b+1,-c);
            update(a2,a,a*c);
            update(a2,b+1,-c*(b+1));
        }
    }
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三更鬼

谢谢老板!

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值