pat1069(误解的代价)

1069. The Black Hole of Numbers (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000
一开始就把题意理解错了,应该是输入整型数字,偏偏自以为是认识输入的是字符串,结果错了错了错了!!!转换了好久的说,最后也没全通过,引以为戒,不过学到了字符和数字转换
#include<iostream> 
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
bool cmp(char a,char b){
	if(a>b){
		return true;
	}else{
		return false;
	}
}
int change1(string a){
	int ans=0;
	sort(a.begin(),a.end());
	for(int i=a.size()-1;i>=0;i--){
		ans+=(a[i]-'0')*(pow(10,(a.size()-1-i)));
	}
	return ans;
}
int change2(string a){
	int ans=0;
	sort(a.begin(),a.end(),cmp);
	for(int i=a.size()-1;i>=0;i--){
		ans+=(a[i]-'0')*(pow(10,(a.size()-1-i)));
	}
	return ans;
}
int main()
{
	int tt;
	cin>>tt; 
	string s1;
	char ss[10]={};
	//itoa(tt,ss,10);
	sprintf(ss,"%d",tt);
	s1=ss;
	int sub=0;
	int t1=0,t2=0;
	while(sub!=6174){
		t1=change1(s1);
		t2=change2(s1);
		sub=t2-t1;
		if(sub==0){
			//cout<<t2<<" - "<<t1<<" = "<<sub<<endl;
			printf("%04d - %04d = %04d\n",t2,t1,sub);
			return 0;
		}else{
			//cout<<t2<<" - "<<t1<<" = "<<sub<<endl;
			printf("%04d - %04d = %04d\n",t2,t1,sub);
			char s2[10]={};
			//itoa(sub,s2,10);
			sprintf(s2,"%d",sub);//数字转成字符串 
			s1=s2;
		}
	}
	//cout<<t2<<" - "<<t1<<" = "<<sub<<endl;
	return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值