Pat(Advanced Level)Practice--1004(Counting Leaves)

Pat1004代码

题目描述:
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1

AC代码:
#include<cstdio>
#include<vector>
#include<deque>
#define MAX 105

using namespace std;

typedef struct Node
{
	int child[MAX];//孩子节点的下标
	int num;//孩子的个数
}Node;

vector<Node> v(MAX);//用下标表示节点编号
deque<int> q(MAX*MAX);

int main(int argc,char *argv[])
{
	int N,M;
	int i,j,k;
	scanf("%d%d",&N,&M);
	for(i=1;i<=N;i++)
		v[i].num=0;
	for(i=1;i<=M;i++)
	{
		int ID;
		scanf("%d%d",&ID,&k);
		for(j=1;j<=k;j++)
			scanf("%d",&(v[ID].child[j]));
		v[ID].num=k;
	}
	q[0]=1;
	k=1;
	for(int l=0,r=1,t=0;l<k;r=k,t++)
	{//t表示树的层数,l表示第t层最左边节点的编号,r表示第t层最右边节点的编号
		int count=0;
		for(;l<r;l++)//每一层节点操作
		{
			int index=q[l];
			if(!v[index].num)
				count++;
			for(i=1;i<=v[index].num;i++)
				q[k++]=v[index].child[i];//孩子节点入队列
		}
		if(t)
			printf(" %d",count);
		else
			printf("%d",count);
	}
	printf("\n");

	return 0;
}

此题还有一个疑问,当输入数据为3,0时即一层上并排有三个叶子节点,输出结果是3呢还是应该为1呢?在判题中结果输出为1,似乎说不通吧。。。
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值