1004 Counting Leave(甲级)

1004 Counting Leaves (30分)
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.
Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:

2 1
01 1 02
Sample Output:

0 1
DFS:

#include<iostream>
#include<vector>
using namespace std;
const int maxn = 101;
struct info {
	vector<int>v;
}node[maxn];
int n, m;
int num_level[maxn]{ 0 };//每层的叶子节点数
int max_depth = -1;//最大深度
void dfs(int root, int depth)
{
	if (node[root].v.size() == 0)//叶子节点
	{
		if (max_depth < depth)
		{
			max_depth = depth;
		}
		num_level[depth]++;
		return;
	}
	for (int i = 0; i < node[root].v.size(); i++)
	{
		dfs(node[root].v[i], depth + 1);
	}
}
int main()
{
	cin >> n >> m;
	for (int i = 0; i < m; i++)//建树
	{
		int parent, value, k;
		cin >> parent >> k;
		for (int j = 0; j < k; j++)
		{
			cin >> value;
			node[parent].v.push_back(value);
		}
	}
	dfs(1, 0);
	for (int i = 0; i <= max_depth; i++)
	{
		if (i != 0)cout << " ";
		cout << num_level[i];
	}
}

BFS:

#include<iostream>
#include<vector>
#include<queue>
using namespace std;
const int maxn = 101;
struct info {//静态树
	vector<int>v;
}node[maxn];
int n, m;
int num_leaf[maxn]{ 0 };//存放每层的叶节点个数
int depth[maxn]{0};//树节点的层号
int max_depth = 0;//最大深度
void bfs()
{
	queue<int>q;
	q.push(1);
	while (!q.empty())
	{
		int value = q.front();
		q.pop();
		max_depth = max(max_depth, depth[value]);//更新最大深度
		if (node[value].v.size() == 0)//如果该节点的是叶子节点
		{
			num_leaf[depth[value]]++;
		}
		for (int i = 0; i < node[value].v.size(); i++)//枚举所有子节点
		{
			depth[node[value].v[i]] = depth[value] + 1;//子节点深度加1
			q.push(node[value].v[i]);//压栈
		}
	}
}
int main()
{
	cin >> n >> m;
	for (int i = 0; i < m; i++)
	{
		int parent,value,k;
		cin >> parent>>k;
		for (int j = 0; j < k; j++)
		{
			cin >> value;
			node[parent].v.push_back(value);
		}
	}
	bfs();
	for (int i = 0; i <= max_depth; i++)
	{
		if (i != 0)cout << " ";
		cout << num_leaf[i];
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值