1004. Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1

题目很简单:对树进行BFS遍历,开一个数组记录对应层号的叶节点个数,遍历时更新即可

#include<iostream>
#include<string.h>
#include<vector>
#include<queue>
using namespace std;
/*
	题目要求:统计每层叶节点个数
	采用树存储:
	由于要求统计每层,故需要进行层次遍历

*/
struct node{
	int layer;
	vector<int> child;
}tree[105];//id作为数组下标
int maxlayer=0;
int childnum[105]={0};//以层数作为下标,记录对应层 的叶节点数
vector<int> ans;

void BFS( ){
	//从01开始
	queue<int> q;
	q.push(1);
	while(!q.empty()){
		int temp=q.front();
		q.pop();
		if(tree[temp].child.empty()){
			childnum[tree[temp].layer]++;
		}
		else{
			for(int j=0;j<tree[temp].child.size();j++){//孩子层数加一,穿到下一层
				int id=tree[temp].child[j];
				tree[id].layer=tree[temp].layer+1;
				if(tree[id].layer>maxlayer)
					maxlayer=tree[id].layer;
				q.push(id);
			}
		}
	}
}
int main(){
	int n,m;
	cin>>n>>m;
	for(int i=0;i<m;i++){
		node temp;
		temp.layer=0;
		int id,k;
		cin>>id>>k;
		for(int j=0;j<k;j++){
			int chi;
			cin>>chi;
			tree[id].child.push_back(chi);
		}
	}
	BFS();
	for(int i=0;i<=maxlayer;i++)
		if(i==0)	cout<<childnum[i];
		else cout<<" "<<childnum[i];
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值