Network of Schools(强连通分量缩点)

A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that if B is in the distribution list of school A, then A does not necessarily appear in the list of school B

You are to write a program that computes the minimal number of schools that must receive a copy of the new software in order for the software to reach all schools in the network according to the agreement (Subtask A). As a further task, we want to ensure that by sending the copy of new software to an arbitrary school, this software will reach all schools in the network. To achieve this goal we may have to extend the lists of receivers by new members. Compute the minimal number of extensions that have to be made so that whatever school we send the new software to, it will reach all other schools (Subtask B). One extension means introducing one new member into the list of receivers of one school.

Input
The first line contains an integer N: the number of schools in the network (2 <= N <= 100). The schools are identified by the first N positive integers. Each of the next N lines describes a list of receivers. The line i+1 contains the identifiers of the receivers of school i. Each list ends with a 0. An empty list contains a 0 alone in the line.
Output
Your program should write two lines to the standard output. The first line should contain one positive integer: the solution of subtask A. The second line should contain the solution of subtask B.
Sample Input
5
2 4 3 0
4 5 0
0
0
1 0
Sample Output
1
2
题意:n个学校,学校可以发送物品到另一个学校(单向)求:
1.最少需要几个学校初始有物品,才能使物品传递到所有学校。
2.最少需要加几条边,才可以实现强连通分量。
思路:很明显的强连通分量,经过强连通分量缩点之后,第一问是所有入度为0的点(因为没有谁能传递给他),第二问是max(出度为0的点数,入度为0的点数)

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
const int MN=110;
int n,e[MN][MN];
int cu[MN],ru[MN];
int num,dfn[MN],low[MN];
int cnt,top,stk[MN],col[MN];
void tarjan(int u)
{
 dfn[u]=low[u]=++num;
 stk[++top]=u;
 for(int i=1;i<=n;i++)
 {
  if(!e[u][i]) continue;
  if(!dfn[i])
  {
   tarjan(i);
   low[u]=min(low[u],low[i]);
  }
  else if(!col[i])
  {
   low[u]=min(low[u],dfn[i]);
  }
 }
 if(dfn[u]==low[u])
 {
  col[u]=++cnt;
  while(stk[top]!=u)
  {
   col[stk[top]]=cnt;
   top--;
  }
  top--;
 }
}
int main()
{
 scanf("%d",&n);
  for(int i=1;i<=n;i++)
  {
   int t;
   while(scanf("%d",&t)&&t)
   {
    e[i][t]=1;
   }
  }
  for(int i=1;i<=n;i++)
  {
   if(!dfn[i]) tarjan(i);
  }
  if(cnt==1)
  {
   printf("1\n0\n");
   return 0;
  }
  for(int i=1;i<=n;i++)
  {
   for(int j=1;j<=n;j++)
   {
    if(e[i][j]&&col[i]!=col[j])
    {
     cu[col[i]]++;
     ru[col[j]]++;
    }
   }
  }
  int d1=0,d2=0;
  for(int j=1;j<=cnt;j++)
  {
   if(cu[j]==0) d1++;
   if(ru[j]==0) d2++;
  }
  printf("%d\n%d\n",d2,max(d1,d2));
  return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值