PTA 第8章结构体与其他结构类型作业 6-7 链表合并 (20分)

本题要求实现一个合并两个有序链表的简单函数。链表结点定义如下:
struct student
{
int data;
struct student *next;
};

函数接口定义:
struct student *merge(struct student *,struct student *);

其中list1和list2是用户传入的两个按data升序链接的链表的头指针;函数merge将两个链表合并成一个按data升序链接的链表,并返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <malloc.h>
#define LEN sizeof(struct student)

struct student
{
int data;
struct student *next;
};

int main()
{
struct student *creat();
struct student *merge(struct student *,struct student *);
void print(struct student *);
struct student *ahead,*bhead,*abh;
ahead=creat();
bhead=creat();
abh=merge(ahead,bhead);
print(abh);
return 0;
}

struct student *creat() //建立链表函数
{struct student *p1,*p2,*head;
int n=0;
p1=p2=(struct student *)malloc(LEN);
scanf("%d",&p1->data);
head=NULL;
while(p1->data!=-1)
{n=n+1;
if (n==1)
head=p1;
else
p2->next=p1;
p2=p1;
p1=(struct student *)malloc(LEN);
scanf("%d",&p1->data);
}
p2->next=NULL;
return(head);
}

void print(struct student *head) //输出函数
{struct student *p;

p=head;

while (p !=NULL)
{printf("%d “,p->data);
p=p->next;
}
printf(”\n");
}

/* 你的代码将被嵌在这里 */

输入样例:
在这里给出一组输入。例如:
2 6 9 -1
1 5 10 -1

输出样例:
在这里给出相应的输出。例如:
1 2 5 6 9 10

struct student *merge(struct student  *ahead,struct student *bhead)
{
 struct student *p,*q,*r,*s;
 p=ahead;
 q=bhead;
 if(ahead->data<bhead->data)
 {
  s=ahead;
  p=p->next;
 }
 else
 {
  s=bhead;
  q=q->next;
 }
 r=s;
 while(p!=NULL&&q!=NULL)
 {
  if(p->data<q->data)
  {
   r->next=p;
   p=p->next;
  }
  else
  {
   r->next=q;
   q=q->next;
  }
  r=r->next;
 }
 if(p!=NULL)
 {
  r->next=p;
  } 
  if(q!=NULL)
  {
   r->next=q;
  }
  return s;
}

完整代码

#include <stdio.h>
#include <malloc.h>
#define LEN sizeof(struct student)
struct  student
{
  int data;
  struct student *next;
};
struct student *merge(struct student  *ahead,struct student *bhead)
{
 struct student *p,*q,*r,*s;
 p=ahead;
 q=bhead;
 if(ahead->data<bhead->data)
 {
  s=ahead;
  p=p->next;
 }
 else
 {
  s=bhead;
  q=q->next;
 }
 r=s;
 while(p!=NULL&&q!=NULL)
 {
  if(p->data<q->data)
  {
   r->next=p;
   p=p->next;
  }
  else
  {
   r->next=q;
   q=q->next;
  }
  r=r->next;
 }
 if(p!=NULL)
 {
  r->next=p;
  } 
  if(q!=NULL)
  {
   r->next=q;
  }
  return s;
}
struct student *creat()                
{
 struct student *p1,*p2,*head;
   int n=0;
   p1=p2=(struct student *)malloc(LEN);
   scanf("%d",&p1->data);
  head=NULL;
  while(p1->data!=-1)
    {
  n=n+1;
     if (n==1)
         head=p1;
      else
        p2->next=p1;
      p2=p1;
     p1=(struct student *)malloc(LEN);
      scanf("%d",&p1->data);
    }
    p2->next=NULL;
   return(head);
}
void print(struct student *head)                                  //输出函数
{
 struct student  *p;
   p=head;
    while (p !=NULL)
    {
  printf("%d ",p->data);
     p=p->next;
    }
    printf("\n");
}
int main()
{
 struct student *ahead,*bhead,*abh;
 ahead=creat();
 bhead=creat();
 abh=merge(ahead,bhead);
 print(abh);
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值