hdu 1102 最小生成树prim模板题

8 篇文章 0 订阅
1 篇文章 0 订阅

作为为数不多的到现在还记得的初三时学过的算法……先来介绍一下什么是最小生成树和prim……

做为一个图,它肯定有很多条边,然后呢,从中选出n-1条边,使得所有点都能连起来,且边权和最小,这就是最小生成树,可以保证n个定点的最小生成树只有n-1条边

然后,关于prim

我初三时的理解是:对于所有边,先选出其中符合条件的最短的一条,符合条件指的是保证这条边的两个顶点有一条没有被选取过,有一条被选取过。接着将这条边插入边集合,将两个顶点也插入点集合,直到所有点都被插入进了集合里。


下面看题

Constructing Roads
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19552    Accepted Submission(s): 7461


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

 

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
 

Sample Output
179
 

题意:裸的最小生成树,只不过有些点间的边权要重新赋值为0

#include<stdio.h>
#include<string.h>
using namespace std;
#define INF 10000000
int dis[102];
int map[102][102];
int vis[102];

int prim(int n)
{  int loc,i,j,k,sum=0;
   memset(vis,0,sizeof(vis));
   for(i=2;i<=n;i++)dis[i]=map[1][i];
   dis[1]=0;
   vis[1]=1;
   for(i=1;i<=n-1;i++)   //一共n-1条边
   {int min=INF;
   	for(j=1;j<=n;j++)if(!vis[j] && dis[j]<min)   //找出离现在联通块最近的点,也就是找出边权最小的边
   	{loc=j;
   	 min=dis[j];
	}
    vis[loc]=1;
	sum+=dis[loc];
	for(j=1;j<=n;j++)         //因为新加入了一个点,更新出每个未加入的点的最短距离
	 if(!vis[j] && dis[j]>map[loc][j])dis[j]=map[loc][j];
		 	
   }
   return sum;	
}



int main()
{
	int a,b,i,j,k,m,n,q;
	while(~scanf("%d",&n))
	{
		for(i=1;i<=n;i++)
		  for(j=1;j<=n;j++)
		   scanf("%d",&map[i][j]);
		scanf("%d",&q);
		while(q--)
		{scanf("%d%d",&a,&b);
		 map[a][b]=0;
		 map[b][a]=0;
		}   
	  printf("%d\n",prim(n));	
	}
	return 0;
 } 

ctr的自我吐槽:只能用这两周做做模板题了……至少省赛遇见了死也要死个明白……

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值