HDU 5573 Binary Tree 找规律二进制

Binary Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 562    Accepted Submission(s): 321
Special Judge


Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is  1 . Say  froot=1 .

And for each node  u , labels as  fu , the left child is  fu×2  and right child is  fu×2+1 . The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another  N  years, only if he could collect exactly  N soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node  x , the number at the node is  fx  (remember  froot=1 ), he can choose to increase his number of soul gem by  fx , or decrease it by  fx .

He will walk from the root, visit exactly  K  nodes (including the root), and do the increasement or decreasement as told. If at last the number is  N , then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given  N K , help the King find a way to collect exactly  N  soul gems by visiting exactly  K  nodes.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case contains two integers  N  and  K , which indicates soul gems the frog king want to collect and number of nodes he can visit.

  1T100 .

  1N109 .

  N2K260 .
 

Output
For every test case, you should output " Case #x:" first, where  x  indicates the case number and counts from  1 .

Then  K  lines follows, each line is formated as 'a b', where  a  is node label of the node the frog visited, and  b  is either '+' or '-' which means he increases / decreases his number by  a .

It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

 

Sample Input
  
  
2 5 3 10 4
 

Sample Output
  
  
Case #1: 1 + 3 - 7 + Case #2: 1 + 3 + 6 - 12 +
 

Source
 



题意:将一棵二叉树的每个点的权值赋为他的编号,一个人从根节点也就是1点出发,总共只能往下走k次。对于每个经过的点,可以选择在已有的值上加上编号或者减去编号,现给你n与k,要求你给出一个路径,使得最后得到的值为n。


思路:考虑最左边的那条路,我们发现可以得到1,2,4,8……所以,最左边的一条路走下来,我们最大可以得到2^k-1,考虑要求得到的数n,我们可以计算出2^k-1-n,这是需要改变的量,每将一个数x的符号从+改为-,那么总和就要减小2x,所以将需要改变的量2^k-1-n除以二,这是要改变符号的数的总和sum。(这里注意如果2^k-1-n不是偶数,那么可以将最后一步改为走右边的那个点,使得最初的总和变为2^k,算差值的时候将2^k-n除以二即可。),将sum写成二进制形式,有1的位数就是要改变符号的位置。比如样例中的n=10,k=4,2^k-1=15,15-10=5为奇数,所以加一,最后一个8改为9,这时候差值是6/2=3,3写成二进制就是11,也就是1+2,所以最后答案就是-1-2+4+9


#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;

int main()
{   long long n;
	int i,j,k,m;
    long long sum=0;
    int t,T;
    long long ans[100];
    int cnt[100];
	ans[0]=1;
    for(int i=1;i<=62;i++)ans[i]=ans[i-1]*2;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {scanf("%I64d%d",&n,&k);
     memset(cnt,0,sizeof(cnt));
   	 int flag=0;  //判断最后一个是不是奇数 
	 sum=0;
	 for(int i=0;i<k;i++)sum+=ans[i];
	 //printf("%I64d\n",sum);
	 long long d=sum-n;
	 if(d%2==1)flag=1;
	 d=(d+1)/2;
	 int cc=0;
	 while(d>0)
	 {
	   	cnt[cc]=d%2;
	   	cc++;
	   	d=d/2;
	 }
	 printf("Case #%d:\n",t);
	 for(int i=0;i<k-1;i++)
	 {
	 printf("%I64d ",ans[i]);
	 if(cnt[i]==0)printf("+\n");
	 else printf("-\n");	
	 }
	 if(flag==1)printf("%I64d +\n",ans[k-1]+1);
	  else printf("%I64d +\n",ans[k-1]);	
     }
     return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值