GCD - Extreme (II) [欧拉函数]

该博客探讨了欧拉函数在输入值N(1 < N < 4000001)时的性质。输入包含最多100行整数N,最后一行为零。输出对应每一行输入的G值,即欧拉函数的计算结果,保证结果在64位有符号整数范围内。提供的样例展示了不同N值下G的计算结果。
摘要由CSDN通过智能技术生成

这里写图片描述

G=0;
for(i=1;i<N;i++)
    for(j=i+1;j<=N;j++)
    {
        G+=gcd(i,j);
    }
/*Here gcd() is a function that finds
the greatest common divisor of the two
input numbers*/

Input

The input file contains at most 100 lines of inputs. Each line contains an integer N (1 < N < 4000001).
The meaning of N is given in the problem statement. Input is terminated by a line containing a single zero.

Output

For each line of input produce one line of output. This line contains the value of G for the corresponding
N. The value of G will fit in a 64-bit signed integer.

Sample Input

10
100
200000
0

Sample Output

67
13015
143295493160

题解

这里写图片描述

#include<stdio.h>
#define MAX_N 4000002
typedef long long LL;
int phi[MAX_N];
LL res[MAX_N],cum[MAX_N];

void init(){
    for(int i=1;i<MAX_N;i++) phi[i]=i;
    for(int i=2;i<MAX_N;i++)
        if(phi[i]==i)
            for(int j=i;j<MAX_N;j+=i)
                phi[j]=phi[j]/i*(i-1);
    for(int i=1;i<MAX_N;i++){
        for(int k=i;k<MAX_N;k+=i){
            res[k]+=1LL*i*phi[k/i];
        }
    }
    for(int i=1;i<MAX_N;i++) res[i]-=i;
    for(int i=1;i<MAX_N;i++)
        cum[i]=cum[i-1]+res[i];
}

int main()
{
    init();
    int n;
    while(scanf("%d",&n)&&n)
        printf("%lld\n",cum[n]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值