【POJ】1456 Supermarket 并查集

Supermarket

Time Limit: 2000MS Memory Limit: 65536K Total Submissions:
12319 Accepted: 5464

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

题解

最直接的暴力+贪心
用z[]记录最优方案,没输入一个数据就一直向前更新最优解,直到为零

#include<stdio.h>
#include<string.h>
#define MAX_N 10002
int z[MAX_N];
int main()
{
    int n,a,t,tmp;
    while(~scanf("%d",&n)){
        memset(z,0,sizeof(z));
        while(n--){
            scanf("%d%d",&a,&t);
            while(a&&t){
                if(a>z[t]) tmp=a,a=z[t],z[t]=tmp;
                t--;
            }
        }
        int ans=0;
        for(int i=1;i<MAX_N;i++)
            ans+=z[i];
        printf("%d\n",ans);
    }
    return 0;
}

使用并查集优化后,艺术啊啊,下面某神的代码太酷了啊啊,无法言表的酷

/*
POJ 1456
贪心处理。
按照获利p从大到小排序。
处理的时候选择最后的一个不冲突点。

用并查集实现链表的作用,快速找到不冲突点
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN=10010;
int F[MAXN];
struct Node
{
    int p,d;
}node[MAXN];
bool cmp(Node a,Node b)//按p从大到小排序。d没有关系
{
    return a.p>b.p;
}
int find(int x)
{
    if(F[x]==-1)return x;
    return F[x]=find(F[x]);
}
int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
        memset(F,-1,sizeof(F));

        for(int i=0;i<n;i++)
          scanf("%d%d",&node[i].p,&node[i].d);
        sort(node,node+n,cmp);
        int ans=0;
        for(int i=0;i<n;i++)
        {
            int t=find(node[i].d);
            if(t>0)
            {
                ans+=node[i].p;
                F[t]=t-1;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

也可以使用优先队列优化

#include<stdio.h>
#include<algorithm>
#include<queue>
#define MAX_N 10002
using namespace std;
struct S{
    int p,d;
}s[MAX_N];
bool cmp(S x,S y){
    return x.d<y.d;
}
bool operator < (S x,S y){
    return x.p>y.p;
}
int main()
{
    int n;
    while(~scanf("%d",&n)){
        for(int i=0;i<n;i++)
            scanf("%d%d",&s[i].p,&s[i].d);
        sort(s,s+n,cmp);
        priority_queue<S> Q;
        for(int i=0;i<n;i++){
            if(s[i].d>Q.size()) Q.push(s[i]);
            else if(s[i].p>Q.top().p){
                Q.push(s[i]);
                Q.pop();
            }
        }
        int ans=0;
        while(!Q.empty()){
            ans+=Q.top().p;
            Q.pop();
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值