HDU - 5477

链接:https://vjudge.net/problem/248423/origin

Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)

Input
In the first line there is an integer t (1≤t≤50), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers: Li,Ri, which represents the interval [Li,Ri] is swamp.
1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L.
Make sure intervals are not overlapped which means Ri<Li+1 for each i (1≤i<n).
Others are all flats except the swamps.

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
Sample Input
1
2 2 2 5
1 2
3 4
Sample Output
Case #1: 0
菜鸡只会做水题,难受啊!

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
struct node
{
    int x,y;
}node[110];
int main()
{
    int n;
    cin>>n;
    int case1=1;
    while(n--)
    {


        memset(node,0,sizeof(node));
        int m,a,b;
        long long int l;
        cin>>m>>a>>b>>l;
        int nn=0;
        for(int i=1;i<=m;i++) {cin>>node[i].x>>node[i].y;nn=nn+node[i].y-node[i].x;}
        nn=nn*a;
        int i=1;
        int sum=0;
        int ak=0;int j=0;
       while(j<=node[m].y)
        {
            if(j==node[i].x) {
               sum=sum-a*(node[i].y-node[i].x);
                j=node[i].y;
                i++;
            }
            else {sum+=b;j++;}
            //if(j==3) cout<<"ads"<<endl;
            ak=min(sum,ak);  //cout<<j<<"  "<<ak<<" "<<sum<<endl;
        }
       printf("Case #%d: %d\n",case1++,-1*ak);
    }
    return 0;
}```

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值