hdu5477 A Sweet Journey

A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 504 Accepted Submission(s): 279


Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)


Input
In the first line there is an integer t ( 1t50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers: Li,Ri , which represents the interval [Li,Ri] is swamp.
1n100,1L105,1A10,1B101Li<RiL .
Make sure intervals are not overlapped which means Ri<Li+1 for each i ( 1i<n ).
Others are all flats except the swamps.

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.

Sample Input
  
  
1 2 2 2 5 1 2 3 4

Sample Output
  
  
Case #1: 0

Source

题意:在区间 [0, L] 中有沼泽和陆地,经过沼泽每米损失a体力,经过陆地每米回复b体力,要从0到L;求在0处所需的最小体力。
分析:因为沼泽都是按顺序排列的,只要把每个沼泽处理一遍,找出某个时候需要的损失的最大体力。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

int main ()
{
    int T,n,a,b,L;
    cin>>T;
    for (int cas=1; cas<=T; cas++)
    {
        cin>>n>>a>>b>>L;
        int p=0,sum=0,minx=99999;//p用来标记上一个沼泽结束位置
        int l,r;
        while (n--)
        {
            cin>>l>>r;
            sum = sum+b*(l-p)-a*(r-l);//没经过一片沼泽所剩于体力
            minx = min(minx, sum);//途中所需的最大体力
            p = r;//更新p
        }
        cout<<"Case #"<<cas<<": ";
        if (minx < 0)
            cout<<-minx<<endl;
        else
            cout<<"0"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值