poj 1273 Drainage Ditches(网络流 最大流)

http://poj.org/problem?id=1273

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

USACO 93

就是一个模板题,我用了当前弧优化的dinic算法,注意一下每次建完分层图后,都要把每个点的当前弧重置为每个点的第一条边

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define exp 1e-8
#define mian main
#define pii pair<int,int>
#define pll pair<ll,ll>
#define ll long long
#define pb push_back
#define PI  acos(-1.0)
#define inf 0x3f3f3f3f
#define w(x) while(x--)
#define int_max 2147483647
#define lowbit(x) (x)&(-x)
#define gcd(a,b) __gcd(a,b)
#define pq(x)  priority_queue<x>
#define ull unsigned long long
#define sc(x) scanf("%d",&x)
#define scl(x) scanf("%lld",&x)
#define pl(a,n) next_permutation(a,a+n)
#define ios ios::sync_with_stdio(false)
#define met(a,x) memset((a),(x),sizeof((a)))
using namespace std;
const int N = 1e6+10;
int tot,n,m;
struct edge
{
    int next;
    int v;
    int w;
    int vis;        //记录当前点u循环到了哪一条边
}e[N];
int head[N];
void add(int u,int y,int z)
{
    e[++tot].next=head[u];
    e[tot].v=y;
    e[tot].w=z;
    head[u]=tot;
}
int depth[N],s,t;
bool bfs()
{
    queue<int>q;
    while(!q.empty())
            q.pop();
        met(depth,0);
        depth[s]=1;
        q.push(s);
        while(!q.empty()){
            int u=q.front();
            q.pop();
            for(int i=head[u];i!=-1;i=e[i].next){
                if(depth[e[i].v]==0&&e[i].w>0){
                    depth[e[i].v]=depth[u]+1;
                    q.push(e[i].v);
                }
            }
        }
        if(depth[t]>0)
            return 1;
        else return 0;
}
int  dfs(int u,int flow)
{
    if(u==t)
        return flow;
    for(int& i=e[u].vis;i!=-1;i=e[i].next){
        if(depth[e[i].v]==depth[u]+1&&e[i].w!=0){
            int di=dfs(e[i].v,min(flow,e[i].w));
            if(di>0){
                e[i].w-=di;
                e[i^1].w+=di;
                return di;
            }
        }
    }
    return 0;
}
int dinic()
{
    int ans=0;
    while(bfs()){
        for(int i=1;i<=n;i++)        //每一次建立完分层图后,都要把vis置成每一个点的第一条边
            e[i].vis=head[i];
        if(int di=dfs(s,inf))
            ans+=di;
    }
    return ans;
}
void init()
{
    tot=-1;
    met(head,-1);
    for(int i=0;i<=m;i++)
        e[i].next=-1,e[i].v=0,e[i].w=0;
}
int main()
{
    while(~scanf("%d%d",&m,&n)){
            s=1,t=n;
            init();
              int u,y,z;
        for(int i=1;i<=m;i++){
            scanf("%d%d%d",&u,&y,&z);
            add(u,y,z);
            add(y,u,0);
        }
        printf("%d\n",dinic());
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值